App Store not loading?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by edtorious, Jun 10, 2015.

  1. edtorious macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #1
    So today i checked my App Store for updates on my iPhone 6+ and then updated all the apps that need updating. And then I went to the feature section of the App Store and nothing loads, I checked the Top Charts and nothing is loading either, nothing is loading except for the Updates which is working fine. I checked the Apple for system status and it looks like all systems are fine.

    I went ahead and closed any background apps, did a soft reset and even shut down my iPhone and nothing is working. I even did network settings reset but still no dice. I would really hate to do a hard reset so before I do that, I'd like to ask if anyone else is having the same problem as I do? Please advise. Thanks.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    I've had that happen once and I don't recall anything in particular making it work aside from after a day or two it just started working fine again on its own basically.
     
  3. steponeman macrumors member

    steponeman

    Joined:
    Jun 13, 2015
    #3
    did you try disconneting from your apple id and login in again? try that and tell us what happened
     
  4. edtorious thread starter macrumors 65816

    edtorious

    Joined:
    Aug 14, 2007
    Location:
    San Diego, California
    #4
    Yes but it did not fix. I ended up just doing a hard reset on my iPhone and restore from backup, it's a pain but that fixed it.
     
  5. steponeman macrumors member

    steponeman

    Joined:
    Jun 13, 2015

Share This Page