App Store not working in Apple Tv 4gen after update

stellarvore

macrumors newbie
Original poster
Sep 17, 2016
8
0
Helsinki, Finland
I Bought today Apple TV 4gen, all works except the App Store After I updated to last TVOs, when I go to purchase/ download any app I make click in one of them to download it and the app doesn't open. You can make click with remote , it moves but doesn't open. I cannot see top charts , categories, purchased or search , when I go to those options the lists doesn't show, I tried rebooting, restoring, disconnecting all cables, resetting my router, connecting to another network, to another Apple ID and nth seems to work.

Anyone having same issue??

is the new TVOs? Cause before I updated I could use normally Apple Store. I'm in Finland btw
 
Last edited:

benjitek

macrumors 6502a
Sep 23, 2012
865
434
It's all working fine for me, currently and prior to the most recent tvOS update. Maybe contact AppleCare tech support?
 

stellarvore

macrumors newbie
Original poster
Sep 17, 2016
8
0
Helsinki, Finland
I am sure is the tvOS update, many people before updating to new tvOS, had their AppleTVs working
I have checked in Apple communities many post related to same.. and other countries, I am going to go to buy a C-Type Usb cable today to restore the device through iTunes, I am not sure if the update through air made the device act stupid, weird thing is iTunes movies works, iTunes itself works, Settings, works, I can mirror my mac there, or some service of mobile Tv I have with my operator.. but when I wanna go to the app store and i click in the app i want to see or download it just shakes and doesn't open.
I will do that and see what happens, if it doesn't work I have two options, take it where i bought it or wait an tvOs update...
If someone has found a solution to this
please share it with me...
 

stellarvore

macrumors newbie
Original poster
Sep 17, 2016
8
0
Helsinki, Finland
Well as i expected seems to be the new TVOs , and seems after you update some of the apple stores in Europe and Asia
stop working, i created an account from United States for testing , I logged in with it in my Apple TV and works .
So seems we need an update to fix this problem. Later I will get the cable type C and i will try to restore the box and see if works, I will update here the result.



EDIT : i bought the C- type cable i restored through iTunes, and the problem persists, then i noticed that when i go to top charts the store become useless and apps do not open, so i restarted again the device and i avoided to go there and the store works, so for now solution is not click in top charts till APPLE releases an update I HOPE!
 
Last edited:

iStillMac

macrumors newbie
May 21, 2016
12
4
Egypt
I just bought an ATV4 today and having the exact same issue when using my Egyptian App Store account, avoiding 'Top Charts' tab would let the other ones work properly. Thanks for the tip!

If I switch to my US App Store account, everything works fine right away.
 

nikusak

macrumors regular
Feb 11, 2014
147
154
Same here, the App Store is dead on tvOS 10, in Finland. It does work as long as you do not try to access the Top Charts tab in the store.

If you do, it renders the App Store unusable. Double clicking the menu button on remote and "killing" the App Store by swiping up on it brings the App Store back to life...until you accidentally let the "cursor" stay a few tenths of second too long on the Top Charts tab and it dies again.

I have filed a bug at https://bugreporter.apple.com/

Probably doesn't hurt if others do too.