App Store not working in Apple Tv 4gen after update

Discussion in 'Apple TV and Home Theater' started by stellarvore, Sep 17, 2016.

  1. stellarvore, Sep 17, 2016
    Last edited: Sep 17, 2016

    stellarvore macrumors newbie

    stellarvore

    Joined:
    Sep 17, 2016
    Location:
    Helsinki, Finland
    #1
    I Bought today Apple TV 4gen, all works except the App Store After I updated to last TVOs, when I go to purchase/ download any app I make click in one of them to download it and the app doesn't open. You can make click with remote , it moves but doesn't open. I cannot see top charts , categories, purchased or search , when I go to those options the lists doesn't show, I tried rebooting, restoring, disconnecting all cables, resetting my router, connecting to another network, to another Apple ID and nth seems to work.

    Anyone having same issue??

    is the new TVOs? Cause before I updated I could use normally Apple Store. I'm in Finland btw
     
  2. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
    #2
    It's all working fine for me, currently and prior to the most recent tvOS update. Maybe contact AppleCare tech support?
     
  3. stellarvore thread starter macrumors newbie

    stellarvore

    Joined:
    Sep 17, 2016
    Location:
    Helsinki, Finland
    #3
    I don't know before i updated was working fine.
    and i have checked other forums and many people has same issue.
     
  4. stellarvore thread starter macrumors newbie

    stellarvore

    Joined:
    Sep 17, 2016
    Location:
    Helsinki, Finland
    #4
    I am sure is the tvOS update, many people before updating to new tvOS, had their AppleTVs working
    I have checked in Apple communities many post related to same.. and other countries, I am going to go to buy a C-Type Usb cable today to restore the device through iTunes, I am not sure if the update through air made the device act stupid, weird thing is iTunes movies works, iTunes itself works, Settings, works, I can mirror my mac there, or some service of mobile Tv I have with my operator.. but when I wanna go to the app store and i click in the app i want to see or download it just shakes and doesn't open.
    I will do that and see what happens, if it doesn't work I have two options, take it where i bought it or wait an tvOs update...
    If someone has found a solution to this
    please share it with me...
     
  5. stellarvore, Sep 18, 2016
    Last edited: Sep 18, 2016

    stellarvore thread starter macrumors newbie

    stellarvore

    Joined:
    Sep 17, 2016
    Location:
    Helsinki, Finland
    #5
    Well as i expected seems to be the new TVOs , and seems after you update some of the apple stores in Europe and Asia
    stop working, i created an account from United States for testing , I logged in with it in my Apple TV and works .
    So seems we need an update to fix this problem. Later I will get the cable type C and i will try to restore the box and see if works, I will update here the result.



    EDIT : i bought the C- type cable i restored through iTunes, and the problem persists, then i noticed that when i go to top charts the store become useless and apps do not open, so i restarted again the device and i avoided to go there and the store works, so for now solution is not click in top charts till APPLE releases an update I HOPE!
     
  6. iStillMac macrumors newbie

    iStillMac

    Joined:
    May 21, 2016
    Location:
    Egypt
    #6
    I just bought an ATV4 today and having the exact same issue when using my Egyptian App Store account, avoiding 'Top Charts' tab would let the other ones work properly. Thanks for the tip!

    If I switch to my US App Store account, everything works fine right away.
     
  7. shogor macrumors newbie

    Joined:
    Sep 23, 2016
    #7
    hello, i've got same problem with Belarussian account.
     
  8. dice316 macrumors newbie

    Joined:
    Oct 17, 2015
    Location:
    Finland
    #8
    Same here, the appstore does not work after the update. Finnish account.
     
  9. MikeatOSX macrumors regular

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #9
    Here in Austria App Store worked before and after update to tvOS 10 without problems.
     
  10. MaciMac100 macrumors 6502

    Joined:
    Oct 26, 2014
    #10
    Same problem here, Appstore doesn't work anymore.
     
  11. nikusak macrumors member

    Joined:
    Feb 11, 2014
    #11
    Same here, the App Store is dead on tvOS 10, in Finland. It does work as long as you do not try to access the Top Charts tab in the store.

    If you do, it renders the App Store unusable. Double clicking the menu button on remote and "killing" the App Store by swiping up on it brings the App Store back to life...until you accidentally let the "cursor" stay a few tenths of second too long on the Top Charts tab and it dies again.

    I have filed a bug at https://bugreporter.apple.com/

    Probably doesn't hurt if others do too.
     
  12. mrex macrumors 68020

    mrex

    Joined:
    Jul 16, 2014
    Location:
    europe
    #12
    "Top-charts" works well here, i quess it was fixed.
     

Share This Page