App Store Not Working in Mojave

Discussion in 'macOS Mojave (10.14)' started by UKStu, Oct 4, 2018.

  1. UKStu macrumors newbie

    Joined:
    Aug 13, 2010
    #1
    Since upgrading to Mojave when I plug in my iPad via a cable to my iMac I get a pop up that says it needs to install an update to connect to the iPad, but if I click install it fails and tells me the update isn't on the server.

    Checking the App store I find that this isn't working.

    If I click the Apple logo in the main menu bar then select App Store the screen blinks but doesn't load anything.
    If I click the App Store from Applications it loads the app store but none of the menu items on the left side like Discover, Create, Work, Categories, etc are there, it only shows one item which is Updates.

    I have tried deleting the caches and plists I even reinstalled Mojave from the CMD + R at boot up.

    Does anyone have any ideas where I can start to try and resolve this?
     
  2. archvile macrumors 6502

    archvile

    Joined:
    Oct 27, 2007
    #2
    Reinstall the OS from Recovery. Not a full wipe, just reinstall the OS on top of itself.

    Also, why do you need to plug your iPad into your Mac? Everything can be done via wireless or cloud nowadays...
     
  3. UKStu, Oct 4, 2018
    Last edited: Oct 4, 2018

    UKStu thread starter macrumors newbie

    Joined:
    Aug 13, 2010
    #3
    I have already reinstalled from recovery, I have also tried installing from a download. Neither has solved the issue.

    If I create a new user the issue is still there.

    I have deleted all the caches relating to the App Store and reinstalled OS and still have the same issue.

    As for plugging in iPad, that is backup and sync via WiFi but I charge it and make the ocassional manual backup via cable. However the issue isn’T the iPad or cable, it is APP Store not loading when clicked from the Apple icon in the menu and only seeing update menu tab when App Store started from Applications.
     
  4. archvile macrumors 6502

    archvile

    Joined:
    Oct 27, 2007
    #4
    Hmm, in that case it sounds like a clean install would be your next step.
     
  5. OcelotWreak macrumors member

    OcelotWreak

    Joined:
    Jul 20, 2011
    Location:
    Canada
    #5
    Are you running Little Snitch? I found that it would not let App Store app execute - said it was missing expected authorized cert, or some such rubbish. Had to go into Little Snitch and explicitly switch off permission requirement for that network thread.
     

Share This Page

4 October 4, 2018