APP store on my iphone won't recognize new apple ID password!

Discussion in 'iOS Apps' started by schoff0310, Nov 25, 2010.

  1. schoff0310 macrumors regular


    Jul 14, 2009
    Southeast Florida
    Ever since I upgraded to 4.2 on my iPhone 4 and installed the new FIND MY IPHONE free app with Mobile Me, I have had problems!

    I set up the account but it gave me a new ID with at the end of my password. I since changed my itunes account on my pc with the new password as I realized I couldn't get on to Itunes, and also checked it on my iphone 4 (by going to utilities and then store). the new password works and shows up - but when I go to the app store on the phone it shows my old ID password as not having the therefore I can't access it.

    I did a soft reset but it still is not:mad: working. So I can't use the store on my iphone at all....

  2. Krisocampo macrumors newbie

    Nov 27, 2010
    I've been having the exact same problem. My app store Password no longer works right after setting up the free 'find your iphone'. In order to sign up for it I had to change my apple ID from a simple username to an email address, once I did that I've been experiencing some trouble. Anyone set it up perfectly without a problem?
  3. Krisocampo macrumors newbie

    Nov 27, 2010
    Nevermind, I figured it out.

    Tap the settings icon
    Tap 'Store' for the app store settings and sign out of your account.
    Sign back in with your new (or other address suffix) and password.

    Everything should work fine after that.
    Let me know if it works!
  4. JulianL, Nov 27, 2010
    Last edited: Nov 27, 2010

    JulianL macrumors 65816

    Feb 2, 2010
    London, UK
    Yes. I did the same thing (to set up my free Find My iPhone) and I broke everything else on both my iPhone and my iPad but for me it was really easy to fix.

    Just go to the AppStore on your iPhone (and all your other iDevices) and it will probably show you as logged in under your old ID and if you try to do something like download an app then it will prompt you for your password and then tell you it's invalid. All I needed to do was go to the bottom of the appstore screen and sign out of my account and then sign back in (to an existing account) using the new name that I'd changed my Apple ID to for the Find My iPhone setup. From then on it all worked OK, my old password was accepted for any prompts when buying apps or downloading updates, and the record of what apps I had was all still OK and accurate so it was just as it was before except for the fact that now it showed me as logged in under my new Apple ID name.

    I don't know if you'll also need to do the same with iTunes, I buy all my music on CD and rip it myself so I've never used iTunes.

    Oops. Our posts crossed. Glad you worked it out.

    - Julian
  5. Krisocampo macrumors newbie

    Nov 27, 2010
    Appreciate the help anyway, julian! Hopefully this thread will help other people as well.
  6. axx macrumors newbie

    Nov 30, 2010
    Same issue here

    I've been trough the same problem, since I upgrade to the 4.2 and installed the Find My iPhone App it forced me to change my ID from a name to an valid email address. I did that, all fine on iTunes, apple TV..etc.

    All went fine until today, I hit the app store from my iphone and I was trying to update and application and the pop up window keeps my old ID. I sign out and put my new ID with my new password and the same thing came out, the old ID.

    I restore my iPhone and the problem continue.

    Any help?
  7. schoff0310 thread starter macrumors regular


    Jul 14, 2009
    Southeast Florida
    Went to apple store. They couldn't fix it!
    I can purchase an app from the store but cannot update any of them as the updates recognize my old password. I was told to do a restore but what I an hearing this will not help.

Share This Page