App store states Lion isn't installed, "About this Mac" says otherwise

derek.fulmer

macrumors member
Original poster
Jun 17, 2010
69
0
Chicago
A couple months ago I did a clean install of Lion because I was having the issue with my Volume level being on full upon starting up my MacBook Pro. I also wanted a bootable DVD of Lion should something happen.

Tonight I was going through the App Store, browsing apps, and decided to see which ones I had hidden and possibly unhide any previously hidden. Lion was an App that I unhid, and now inside the bar across from the App name in the "Purchases" section it says "INSTALL."

However, when I read the info in my About this Mac, it reads 10.7.3.

What's the reason for this? How do/can I fix this? I'm pretty anal retentive about things such as this and would like to resolve it.

Thanks,

Derek
 

ezramoore

macrumors 6502a
Mar 20, 2006
612
3
Washington State
If you installed from a DVD (or anywhere BUT the MAS) this is to be expected.

Just like MAS not recognizing Aperture or iLife apps that were not bought AND installed from the MAS.
 

HenryAZ

macrumors 6502a
Jan 9, 2010
606
97
South Congress AZ
I have Lion, from the MAS, installed on two machines. I did this last July.

Sometime in the last week, both machines started showing in the MAS that Lion is not installed (the Install button is highlighted). All updates are current on both machines, too.
 

iVoid

macrumors 65816
Jan 9, 2007
1,117
137
More than likely it's saying the installer application isn't currently installed.

I wouldn't worry about it.