App Store updates downloading twice?

Discussion in 'iOS 10' started by alanderp, Sep 28, 2016.

  1. alanderp macrumors regular

    alanderp

    Joined:
    Sep 15, 2016
    #1
    Received my 7+ yesterday, updated a few apps in my phone with the app store update screen open, and I noticed the apps download twice (download circle bar goes around twice) before fully updating. Anyone with this issue? Not sure if it's actually downloading twice or if it's just glitches.
     
  2. Böhme417 macrumors 6502

    Joined:
    Mar 11, 2009
    #2
    There does seem to be some iOS 10 issue with app updates. Both my iPhone 6 and iPhone 7 have the same problem on 10.0.1 with partially downloading app updates, stalling, and then restarting the download. Sometimes they will get stuck displaying a partial download. I have to force quit the app and restart to see that the app has downloaded. Annoying.
     
  3. alanderp thread starter macrumors regular

    alanderp

    Joined:
    Sep 15, 2016
    #3
    Hmm my 6S+ is working perfectly fine on the same 10.0.2 firmware.

    On my 7+ it shows it downloads completely and I think it's about to install but instead it clears the download progress and it looks like it downloads again...

    7+ been having weird issues since I received it compared to my 6S+ :C
     
  4. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #4
    this been randomly happening for years its not ios 10..
     
  5. Böhme417 macrumors 6502

    Joined:
    Mar 11, 2009
    #5
    I agree that it has happened sporadically before, but it's happening with EVERY app update I've had since iOS 10.
     
  6. dlondon macrumors 6502

    Joined:
    Sep 6, 2013
    #6
    My iPhone 7+ was running hot this morning and the battery drained within a few hours. I plugged in while at work but my day was so hectic I didn't really have time to look it at. I checked my data usage and have discovered that my phone has used 15GB of mobile data trying to download one or possibly two apps from the app store. I have switched off mobile data and deleted the two apps it could be but I now have problems with the App store app. I can open the app but it doesn't let me do very much. It shows that I have 10 apps ready to be updated but I can't navigate. I've switched off, tried resetting and have reset the network settings. My next option is to do a full reset I guess.
     
  7. alanderp thread starter macrumors regular

    alanderp

    Joined:
    Sep 15, 2016
    #7
    Did you restore from a backup or as a new phone? It's just really weird if it's been happening for years because I've never experienced this ever since I've had an Iphone 3G...
     
  8. alanderp thread starter macrumors regular

    alanderp

    Joined:
    Sep 15, 2016
    #8
    Restored my 7+ through iTunes + backup, and apps only update once now so that's fixed, animation lags are still there for the most part.

    I guess it might have something to do with OTA updates sometimes, but OTA update to 10.0.2 is what I did straight from the box.
     
  9. dlondon macrumors 6502

    Joined:
    Sep 6, 2013
    #9
    Never happened to me before. I always restore from backup as I have many apps (with data on them and not all backup to the cloud) and don't like spending time getting them all reinstalled either. I've been using the phone for a week without any issues. It only happened today when the app Fantastical was being updated. I've deleted the app now but there's something else going on I think. I switched my data on for about 5 mins today and it downloaded 1GB under media services. I may setup as a new phone this weekend but such a hassle.
     

Share This Page