app stuck on grey waiting

Discussion in 'iPhone' started by Sossity, Aug 30, 2011.

  1. Sossity, Aug 30, 2011
    Last edited: Aug 30, 2011

    Sossity macrumors 6502a

    May 12, 2010
    I have an iphone 3gs that is jailbroken & untethered ios 4.3.3 with t-mobile.
    am using mac os 10.6.8

    I recently tried to access the apple apps store over a wifi network, & an app appeared ibooks, that I wanted to download, & I could not get into my itunes store account, I had forgotten my password. I then had to leave the place with the wifi, & now I have a mystery grey app waiting icon.

    I cannot remove it, I have tried, resets, reboots, turning on & off with red slider. re syncing, removing all my apps & re syncing, I even went out to another place with free wifi, to try to access the apps store, but it could not access the app store.

    I have since downloaded & added ibooks to my iphone from my home computer, but the mystery grey app is still there.

    I cannot do a restore as I dont want to lose my jailbreak & tmobile account

    am I forever stuck with this? should I just leave it & be happy the rest of the phone works?will it cause serious problems with the phone?

Share This Page