App to fake firmware version?

Discussion in 'Jailbreaks and iOS Hacks' started by bbplayer5, Aug 27, 2010.

  1. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #1
    I am currently on 4.0.1 (with the 4.0.2 patch) and I am trying to install a keyboard replacement app. It says I need 4.0 to install it. Is there an app that can make my phone think its running 4.0?

    Thanks.
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Why would you want to do that, if the application say that you need a specific version is for a reason (they are not just saying that to annoy you).
     
  3. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
    #3
    Wasnt really looking for a reason not to try it. Was looking for the app to do it. Doesnt really concern you why I would do it.
     
  4. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #4
    That response will inspire maturola to help you!

    S-
     
  5. spencers macrumors 68020

    spencers

    Joined:
    Sep 20, 2004
  6. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
    #6
    Where is that located?

    Thanks.
     
  7. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #7
    I actaully got a couple of way how to do it, but I just wanted to make sure you don't screw up your system, but since that is not my concern them go figure it out yourself and get an advice from unexperienced users and brick your phone.

    A little dramatic I know...:D:D:D

    And yes, go modify the Info.plist manually and them sync it to a Apple server and please please please come back and share a Screenshot :D LOL
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Generally when an app requires a specific version, it means that is the minimum version required to run the app.

    In other words, the app should run on 4.0, 4.0.1 and 4.0.2.

    Keep in mind, except for iAccess keyboard mods, WinterBoard keyboard mods will not work unless you are on 2.x.x firmware.
     
  9. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #9
    There are only 798 files with that name on my iPhone.

    S-
     
  10. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
    #10
    Exactly what im trying to do but it wont install. Says I need 4.0. Figured it would work with 4.0.2 but I cant force it on etc.

    Thanks.
     

Share This Page