App to trick iphone firmware into thinking its a different firmware?

Discussion in 'Jailbreaks and iOS Hacks' started by jsook724, Oct 6, 2009.

  1. jsook724 macrumors regular

    Joined:
    Aug 2, 2008
    Location:
    CA
    #1
    hi,
    i forgot what its called, or what the source is.
    one thing i do remember about it is that it was by gojonnyboi.

    does anyone know what it is???
     
  2. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #2
    At the risk of digging up a VERY old subject-I need this too. I have a 1G iPod touch on 3.1.3 and want to listen to TuneIn Radio. When I try to download to the 1G, it says it requires 4.X.

    I seem to remember something on Cydia that would do this but can't find anything and can't remember the name.

    Thanks as always!
     
  3. Cooolpenner macrumors regular

    Joined:
    Jul 8, 2011
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
    just tell Itunes not to update and not to remind you. or just don't update much better and safer.
     
  5. rrandyy macrumors 6502

    Joined:
    Jan 14, 2009
    #5
    "Firmware Changer is available for free in Cydia via ModMyi repository."
     
  6. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #6
    There's another method that doesn't require any additional tweaks. Navigate to system/library/coreservices and open systemversion.plist. Replace the version and build number strings and you're done. Make a backup first though.
     
  7. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #7
    Hmm

    After considering all the options, I JB my 3.1.3 with the original jailbreakme.com and then just installed software from iTunes instead of downloading it directly to the 'touch.

    Interesting that software that "requires" 4.X, like TuneIn Radio install just fine when the 'touch is tethered to the Mac. Can't understand the error message when trying to directly download though?!?
     

Share This Page