App Update failed- Stuck in loop

Discussion in 'iPhone Tips, Help and Troubleshooting' started by HexusOdy, Sep 23, 2009.

  1. HexusOdy macrumors newbie

    Joined:
    Sep 23, 2009
    #1
    Hi Guys,

    I use Sygic GPS software for Europe and this morning I was told there was an update to download. So I go to the app store and start the update while connected to WiFi and it all went as usual.

    After a couple of minutes my router reset and I lost WiFi, at which point my iPhone tells me that the update is over 10mb and should only be downloaded over WiFi and that the download will stop. Not a problem I though, I'll do it when WiFi is back.

    The problem is the App Store thinks its finished downloading but my phone doesnt. But for the last 6 hours the little circle in the top bar has been constantly going like its trying to download and every time I turn my phone off then on again I get the same message about only downloading the App update over WiFi. And the little spinning circle starts again.

    I though if I removed the Sygic app that might fix it, but when I turned my phone back on I now just have a blank grey app icon with "Loading" underneath like its trying to download the update without the app being there.

    Apart from it chewing battery I haven't been able to receive calls all day. For some reason I can dial out but not get anything in.

    I'd restore on iTunes but that wants me to install 3.1 at the same time and I aint going there!

    Any ideas?
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    Maybe if you sync the phone, then delete the App in iTunes, then sync again and refuse the iTunes request to transfer the app from the phone, that would work? I have not had this problem so I'm just guessing....
     
  3. iSpaghettiCat macrumors regular

    Joined:
    Sep 4, 2009
    Location:
    Miami, FL
    #3
    Try tapping the icon a couple of times with your Wi-Fi on. This has happened to me twice or so.
     
  4. HexusOdy thread starter macrumors newbie

    Joined:
    Sep 23, 2009
    #4
    I fixed this problem by getting iTunes to download the update for Sygic then resyncing the app to the iPhone.

    I guess once it detected the app was the new version it corrected itself and removed the icon.
     

Share This Page