App updates don't download either on iPhone or iTunes

Discussion in 'iPhone' started by fishmoose, Dec 12, 2009.

  1. fishmoose macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #1
    Hi,

    A strange problem started like a week ago, when there's an update for an app I can download it from either the iPhone or iTunes but it won't delete the old file or something because when I check for updates again it says I have an update and it's the same I just downloaded! Sometimes I download the update the phone shows it's installing it and I open the app and it hasn't updated.

    Anyone else has this problem?

    Thanks for your time!
     
  2. bigpatky macrumors regular

    bigpatky

    Joined:
    Sep 7, 2007
    #2
    same problem here. specifically Political GPS finally quit asking me to update after a week of updating and watching it install only to tell me in the app store that the same update was available. Beejive had an update last night and it came back 3-4 times before it looked like it finally "took." I've been fighting with Movie Genie since last night too. That one is obvious because as it installs, the app's new updated icon shows up and as it finishes installing, the old icon pops up again. I tried restarting the phone but nothing helps. any suggestions? 32gb 3Gs running 3.1.2.
     
  3. Interpolation macrumors regular

    Joined:
    Jan 11, 2008
    #3
    If you look at the version of the file that is downloaded you will see that it is always the old version, even though itunes says there is a new version, hence it will always tell you that you have an app to update.

    It seems as if a new app is uploaded to itunes store by the developer, the store realises there is an update and tells you, but the actual file is not on the server, or the it's still pointing to the old file, so it downloads the old file, and you get the meesage that you still have an update.

    Eventually it gets sorted out in the store and the correct version does download. As to where the problem lies, I would say it's with the apple servers.
     
  4. fishmoose thread starter macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #4
    Yeah I figured that out when I tried to update BeejiveIM just now. So this is up to Apple to fix? Glad it's not just me.
     
  5. bigpatky macrumors regular

    bigpatky

    Joined:
    Sep 7, 2007
    #5
    that makes sense. i guess i just need patience. although the server does, however, have the new logo for the movie genie app i mentioned. it appears while "installing" but disappears when it's finished.
     
  6. Hughm macrumors member

    Joined:
    Dec 12, 2009
    Location:
    Vancouver
    #6
    non-updating updates

    Glad to see others have had this problem!!

    Mine occurred with Motionx GPS and Distant Suns (astronomy). The first has been resolved; I'm waiting for the second to do likewise.
     
  7. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #7
    i've had this problem countless times, even unistalling and reinstalling doesnt work :p

    come'on apple fix it!! we got app hngry fools waiting for updates!!
     
  8. JustLeft macrumors 6502

    Joined:
    Sep 20, 2007
    #8
    I have also had the same issue and have reported it to apple. Been going back and forth with them, and I am told it has been forwarded to their technical department. I wonder how much bandwidth is chewed up on apple servers due to this issue. All of these downloads, done over and over again, with old code versions being updated. What a waste.
     
  9. fishmoose thread starter macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #9
    It should be in there interest to fix it, let's hope they do it fast!
     
  10. Clete2 macrumors 65816

    Clete2

    Joined:
    Sep 20, 2008
    Location:
    USA
    #10
    Same problem here. I tried to update BeejiveIM last night, to no avail. This morning, I downloaded it, and it worked.

    They fixed the bug with adding buddies! :)
     
  11. rich2000 macrumors member

    Joined:
    May 18, 2009
    #11
    It's a bug in the App Store

    From what I've deduced basically

    OLD SYSTEM

    1) Developer gets approved for sale email from Apple
    2) Around 3 hours later the update appears in the app store

    NEW SYSTEM

    1) Developer gets approved for sale email from Apple
    2) The update shows in the app store pretty soon afterwards but with the OLD binary
    3) Anywhere from 3-12 hours later the new binary appears. I'm guessing the binaries are cached but doesn't excuse the bug
     

Share This Page