App updates not showing in App Store until reboot

Discussion in 'OS X El Capitan (10.11)' started by bookemdano, Jun 10, 2016.

  1. bookemdano macrumors member

    Joined:
    Jul 29, 2011
    #1
    Since updating to 10.11.5 on all my machines (not that I think that's necessarily the cause--just a correlation) I'm seeing a weird issue whereby any MAS-purchased apps are not showing updates in the updates tab (I get the "No Updates Available" banner). These are apps which I know for a fact have been updated and the app store shows newer version numbers than what I have installed. It affects all apps, as far as I know. When I visit those apps' pages in the app store the button says "OPEN" rather than "UPDATE". I first experienced this issue a couple of weeks ago and it persists even through today.

    I've tried signing out and back into my Apple ID in the app store app (also I only have one Apple ID and have used to that to purchase all of my apps), and also tried force quitting the app along with the softwareupdated service--no change at all. The only talk about this issue I've found online was an issue with Yosemite involving having added the boot volume to Spotlight exceptions (not the case here--I have nothing in the Spotlight exceptions list).

    The only thing that does work is rebooting. After I reboot and log back in, the App Store Updates tab will suddenly show all the app updates which it previously was not. I can install them and everything's great, until x amount of time later, the same thing happens.

    I would suspect some sort of local corruption issue, except that this is happening in exactly the same way on TWO different Macs--a 13" 2013 MBPr and a 13" 2011 MBA. Given that there is no widespread discussion about this problem, my best guess is that the cause is some app I have installed on both Macs which is breaking the App Store update mechanism.

    But short of deleting apps at random one-by-one I'm not sure of another way to troubleshoot this. The biggest problem with manually troubleshooting is I'm dependent upon new app updates actually being released to see if the app store updates tab shows them (and I don't have enough Mac apps to have that be a daily occurrence. I'm lucky if there is one app update available every week).

    So is there anyone out there who knows enough about what triggers MAS update notifications that can help me figure out if there's a specific service I need to get logs for to help figure this out? At a minimum is there a specific service I can kill and restart as a temporary fix rather than rebooting the whole machine?

    Much appreciate any ideas.
     
  2. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #2
    Just for a temporary work around -- Have you tried pressing command,r ? That refreshes an open, MAS pane.
    --- Post Merged, Jun 10, 2016 ---
    Found a reference to this at Apple and a post at Ask Different. The poster suggested (if not already there) to add the boot volume to the Spotlight privacy list, then remove it, reboot, and wait for Spotlight to re-index the drive. Seems worth a try.
     
  3. bookemdano thread starter macrumors member

    Joined:
    Jul 29, 2011
    #3
    Thanks for replying. I should have mentioned it but yeah Command-R makes no difference. It does trigger a refresh but the "No Updates Available" banner remains.

    I should also mention I enabled the debug menu of the app store and tried the clear cache and reset commands with zero change. There's some logging stuff in there too, but I don't want to mess with that without some direction because I don't know how the app store updates process works in the first place. I do know that MAS updates normally appear more-or-less instantly after going to the Updates tab, and the OS updates appear only after the "Checking for updates" process completes. So there are multiple things going on under the hood I don't really have a technical grasp on.

    I saw the article about the Spotlight issue but it didn't seem to apply in my case because I have never used the privacy list in the first place. But I guess I have nothing to lose by trying the steps they mention. I'll give it a shot on my work computer here before I leave today and then will see if on Monday it shows the app updates--that should give it plenty of time to re-index.

    I have to say though I really doubt that is the cause here, since this is happening on two of my machines. Any other ideas?
     
  4. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #4
    Neither do I. I've not changed any setting in the debug menu but I would be tempted, if it came to it, to change the verbosity level. If you have the same security software on the machines, obviously, that could be your culprit. The only reference I've found to a specific software conflict was in a 4.5 year old post HERE.
     
  5. janezblond macrumors member

    janezblond

    Joined:
    May 15, 2013
    #5
    Just wanted to add my name to the list. Having this issue with two Macs, both of them fresh installations. As with the OP, restarting fixes the issue temporarily.
     

Share This Page