App Updates

Discussion in 'iPod' started by LePigeonBleu, Jul 25, 2009.

  1. LePigeonBleu macrumors 6502

    Jul 11, 2008
    San Diego

    I have searched, and found nothing... so here's my dilemma:

    I have only one iTunes account, so there is no issue there...

    I clicked on check for updates, and found that there are several updates available for my apps. When I click to download them, it brings me to a screen telling me there are no updates currently available. I can't see what apps need updating, it just brings me to that screen.

    I've called Apple, and they have no idea what is wrong. I've tried creating a new library and that does not work. I've uninstalled iTunes 8.2.1 and nothing. Restarting the computer doesn't do anything, nor does repairing permissions.

    Anyone have an idea on what is wrong and how to fix it?


  2. JediMeister macrumors 68040

    Oct 9, 2008
    Have you tried deleting the affected applications from the iTunes Library on your computer, and redownloading them from the App Store? I remember seeing something on another thread about some app developers having changed the filenames of the .ipa downloaded from the App Store, which could potentially explain why the App Store initially reports you have updates but then can't find them...
  3. LePigeonBleu thread starter macrumors 6502

    Jul 11, 2008
    San Diego
    Only problem is that it doesn't show me what apps need updating. So, I wouldn't know what to delete.


Share This Page