App will not compile....Help Please

Discussion in 'iOS Programming' started by talguy, Jun 17, 2009.

  1. talguy macrumors member

    Joined:
    Jun 17, 2009
    #1
    I am new to programming for the iphone. I tried to do the basic hello world app using a static label and a static image view. When I compile the application i get the following error while trying to link the main file and the appdelegate.

    I also just upgraded my computer from tiger to leoprad and I did not do a fresh install.

    Thanks in advance

    Evan
     
  2. talguy thread starter macrumors member

    Joined:
    Jun 17, 2009
    #2
    I just tried to do a normal cocoa desktop hello world application and got the same errors. So the error is xcode in general.
     
  3. Paix247 macrumors 6502

    Joined:
    Jul 26, 2006
    Location:
    Minneapolis
    #3
    I had this problem recently as well. The way I eventually fixed it is by reverting to an earlier copy of the folder via Time Machine... good luck!
     
  4. talguy thread starter macrumors member

    Joined:
    Jun 17, 2009
    #4
    I can't revert to an older version since I just upgraded to leopard. But I did uninstall all the developer tools by running this command

    sudo /Developer/Library/uninstall-devtools --mode=all

    I then reinstalled xcode and the iphone sdk and have had no luck.
     
  5. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
  6. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #6
    Do the files that it says it can't find exist or not?

    It's possible that this is a permissions problem.

    Can you show the link line from the build transcript?
     
  7. talguy thread starter macrumors member

    Joined:
    Jun 17, 2009
    #7
    When I build the app code never makes the object files. I can make these files if I click on the file and select compile. But when I click build and with the files already compiled I still get the same error.

    So right now code can not link C, C++ and Objective-C programs. Java Works. So it has to be somethign with gcc.

    Here is the build transcript

    Evan
     
  8. talguy thread starter macrumors member

    Joined:
    Jun 17, 2009
    #8
    Please ignore my last post. I got it working.

    What I did was change the build path from "/Users/macuser/Desktop/Evan's/projects" to "/Users/macuser/Desktop/Evans/projects"

    Thanks for all the help

    Evan
     

Share This Page