App will not uninstall and it is hanging my sync

Discussion in 'iPhone Tips, Help and Troubleshooting' started by blue2noise, Jul 24, 2010.

  1. blue2noise macrumors regular

    Joined:
    Jul 23, 2008
    #1
    Hopefully you guys can help me. I have an iPhone4 running iOS4.01. I tried to uninstall the Citibank Mobile app and while it appeared to be removed, when i sync with itunes it says about halfway through the sync "removing citibank" and will not get past that section.

    I have tried:

    Rebooting the phone (hard reset)
    Removing the app from iTunes (and moving it to the recycle bin)

    I cant get past it and now cannot sync without hanging at "Removing Citibank" . Any ideas on how I can get rid of this thing??

    Thanks in advance for any help.
     
  2. blue2noise thread starter macrumors regular

    Joined:
    Jul 23, 2008
    #2
    Just tried downloading it again from itunes to "re-install it". It goes through sync normally but the app is nowhere to be found on the phone even though it is check in "apps". So strange.

    Can't install it. Can't remove it.
     
  3. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #3
    Have you tried removing it from your 'phone by un-checking it in the Apps section in the "Devices" section of iTunes and then re-syncing?
     

Share This Page