app won't run on anything below 3.1.2

Discussion in 'iOS Programming' started by chenks, Dec 15, 2009.

  1. chenks macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #1
    i've built an app and just found that it doesn't run on anything below 3.1.2, when it should have been nothing below 3.0.

    looking at the screengrab of the project "get info", am i correct in saying that i should change the "base SDK" from 3.1.2 to 3.0 ?
     

    Attached Files:

  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    No.

    Set Base SDK to the highest OS that you support, 3.1.2 in this case. Set iPhone OS Deployment target to the lowest OS that you support, 3.0 in this case.

    You would need runtime checks in the code for any features introduced after 3.0 that you use.
     
  3. chenks thread starter macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #3
    ok thanks.

    what is the "best practise" for this at the moment. is it to build for v3.0 and above?
     
  4. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #4
    There's not really a best practice.

    If you want to support OS 2.x I would recommend only supporting 2.2.1.

    If you need any feature from 3.1 or later I would set the deployment target to the OS version that has that feature.

    It's a free update for all users up to 2.2.1. It's a free update for all users that own 3.0 to the latest OS so I don't see the down side with requiring the latest OS if you already require 3.x.

    If you require 3.0 but don't use any feature from 3.1 then I guess it's up to you. 3.0 or 3.1 is probably the same from the user perspective.
     
  5. hoosierfan24 macrumors member

    Joined:
    Jul 31, 2009
    #5
    I would say to build for 2.2.1 because I made the mistake and built for 3.0 and i think it has hurt my sails because not that many people paid for the upgrade seeing that there was not to much of a difference so i would recommend 2.2.1
     
  6. boyplunder macrumors regular

    boyplunder

    Joined:
    Sep 8, 2008
    Location:
    UK
    #6
    Moving up

    I was about to start a new thread, but I think this is on a similar line.

    I have an app that currently runs in 2.2.1 and up, but a few additions I want to make will be 3.0 upwards only. Does anyone have a view on the best route forward, given there may be some users still using 2.2.1? iPod users probably.

    My view is that I explain it in the update info when it appears on the store. That way the user can decide for themselves.
     

Share This Page