Apple 23" ACD problems fix or replace?

Discussion in 'Mac Accessories' started by Avro, Jan 1, 2012.

  1. Avro macrumors regular

    Avro

    Joined:
    Mar 30, 2008
    Location:
    Belgium
    #1
    Oh dear this year is not starting out well. :(

    I shut off my Mac Pro for a couple of hours this morning and when I tried to start it the 23"Apple ACD wouldn't start. The light doesn't come on and when I press the monitor start button I get a brief blink (sometimes or nothing). I tried zapping the PRAM and after many restarts no progress.

    My basic thought is that the Power Supply is dead.

    A new one would set me back about £125 or I could go for an Acer 27" monitor for about £263.

    The 23" ACD is about 2 months out of warranty, I had trouble with the previous one and had it replaced last year so I'm not terribly keen on the beast.

    Should I get a new power supply or a new monitor? Advice would be appreciated.
     
  2. kellen macrumors 68020

    kellen

    Joined:
    Aug 11, 2006
    Location:
    Seattle, WA
    #2
    get a new power brick from ebay, should solve your problems. Try for the 30" power brick, it will work and doesn't have the problems that the 20 and 23" ones have.

    Leaving it disconnected for a few minutes or plugging it in and unplugging 5 times quickly has brought mine back to life.
     
  3. yomibro macrumors regular

    Joined:
    Feb 24, 2008
    #3
    If you are looking for a good replacement Dell's U2711 is on sale today for $699 at the US site
     
  4. Avro thread starter macrumors regular

    Avro

    Joined:
    Mar 30, 2008
    Location:
    Belgium
    #4
    I went to the Apple Store in Sheffield and they diagnosed a u/s power brick. The new one cost me £72 and I will pick it up tomorrow. :cool:
     
  5. RedCroissant Suspended

    Joined:
    Aug 13, 2011
    #5
    Hey Avro,

    I know that this is a VERY old thread, but I wanted to ask you something about your configuration before the power brick was diagnosed as faulty.

    I recently bought my PowerMac G5 with a 23" display and started noticing this problem recently as well. Every time it happened I wouldn't be able to get my display to come back on either after the machine was put to sleep of the display itself was sleeping. So every time I would simply change the DVI port that the display was plugged into and then unplugged it and then plugged it back in and everything would be fine.

    Because of this weird "power thing" and seeing that other people were having the same issues I was wondering if it was just my configuration that caused the problem. It also had issues with recognizing usb devices connected via the ports on it.

    After disconnecting the usb and FW cables from the tower and doing that crazy unplug/plug-in routine, I realized that the monitor might not be getting enough power since it was plugged into a power strip along with my PM, an external HDD, the charger for my iPad and the charger for my phone. Once I plugged the monitor directly into the outlet, all the problems went away and the monitor actually works better now than when I first got the machine.

    So sorry for the long response to such an old post, but I was just curious to know exactly what you were experiencing and what you tried to before replacing the power brick. Thanks!
     

Share This Page