Apple 23" HD Cinema Display no longer working with new Macbook Pro

Discussion in 'Mac Accessories' started by sixfive, Sep 9, 2009.

  1. sixfive macrumors newbie

    Joined:
    Sep 9, 2009
    #1
    First post here and I'd be hugely appreciative of some help.

    I bought a 23" used HD Cinema display the other day along with the ADC-DVI and DVI-Mini Display adapters. I had it hooked up and it was working perfectly for 3 days. Today my wife tried to connect her Macbook accidentally via the USB that is part of the ADC-DVI adapter which didn't work (why is that USB there anyway?). Then when she went to connect the external display back to my Macbook Pro it did not wake up after being connected.

    I have tried resetting the PRAM on the MBP and have disconnected and re-connected all connections but nothing will get the display working with the MBP anymore. When I connect and disconnect the mini-display plug into the MBP the MBP flashes the blue screen as it appears to be reacting, but that's it. I can't detect any display when I go into the display system preferences. Does anyone know how I can get the Apple Cinema display working again?

    Thanks for any help!
     
  2. occamsrazor macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #2
    It relays the host computer's USB port to the display, enabling the use of the two USB ports on the back of the display.
    Sorry I can't help with your main problem, though I can't see any reason in theory why connecting that USB plug to your wife's Macbook could have caused the problem...
     
  3. sixfive thread starter macrumors newbie

    Joined:
    Sep 9, 2009
    #3
    thanks, that makes sense. Probably had nothing to do with it..
     
  4. sixfive thread starter macrumors newbie

    Joined:
    Sep 9, 2009
    #4
    Replaced the DVI to mini-display adapter and that fixed the problem, so it was a bad adapter (or one that went bad).
     

Share This Page