Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Apple AirPod pro right AirPod not working?

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
I’m really not happy or impressed after spending so much on these.

Have only had them a couple of months all was working fine tried to listen to some music the next day and the right AirPod no sound. Have tried all the basics and don’t know what else I can try.

I don’t fancy going into an Apple store to get it sorted as it’s far away from me and I would have to send them off resulting in being without my music on my commute for abit.

Is this a common problem? I’m totally not impressed this is happening at this price point any other people had this problem? Anything else I can try to get the right one to work. Thanks in advance. I feel totally let down.
 
Last edited:

BF1M

macrumors 6502a
Nov 17, 2018
628
772
I came on here tonight to post the same thing(in different thread though). My right AirPod pro hardly ever works at all; doesn't even register it's in my ear. I've only had mine for about 4 days.
 
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
I came on here tonight to post the same thing(in different thread though). My right AirPod pro hardly ever works at all; doesn't even register it's in my ear. I've only had mine for about 4 days.
Same I get no sound in the right one nothing. All was working fine the day before so really don’t know how this happened from out of no where.
 
Comment

BF1M

macrumors 6502a
Nov 17, 2018
628
772
For me it's 9 out of 10 times it won't register being in my ear. If I delete from iCloud and reconnect it will work for that first time then nothing usually.

On my iMac, iPad, Apple Watch, the same thing.

Guess we got bad ones...
 
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
For me it's 9 out of 10 times it won't register being in my ear. If I delete from iCloud and reconnect it will work for that first time then nothing usually.

On my iMac, iPad, Apple Watch, the same thing.

Guess we got bad ones...
I guess we did as spoke to Apple on the phone went through all the steps with them to try to get it to work but no luck so don’t know what else I could try. So got no choice but to take them in which is all such an inconvenience for me. I’m far from impressed only had them a couple of months and this happens.
 
Comment

BF1M

macrumors 6502a
Nov 17, 2018
628
772
It’s an inconvenience for sure. I may just return them outright and stick with gen 2 versus a replacement. I don’t usually get bothered by all the hype surrounding faulty Apple devices but there is a lot of bad info about the Pros floating around here and other places.
 
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
It’s an inconvenience for sure. I may just return them outright and stick with gen 2 versus a replacement. I don’t usually get bothered by all the hype surrounding faulty Apple devices but there is a lot of bad info about the Pros floating around here and other places.
Yeah this has really put me off them this experience is leaving a sour taste in my mouth. So seems like there are some common issues going around with these then. I can’t say I’m surprised by that with what I’m going through with them right now. Makes me feel like this was a product rushed to quickly out the door.
 
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
I often have to re-insert one of them into the case and let it 'sync' and then it starts working again. not sure if that's related, but it's just as annoying.
It’s worth a shot I guess anything is really. So just put one in that don’t work close the lid for how long? And how do I know it’s syncing?
 
Comment

ttforever

macrumors regular
Aug 13, 2015
161
52
I had that from my launch pair, eventually stopped working totally went to apple store and they replaced the right one and been fine ever since
 
  • Like
Reactions: SHKLMRE
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
I had that from my launch pair, eventually stopped working totally went to apple store and they replaced the right one and been fine ever since
Guess that’s what they will do for me then just swap out the right one.
 
  • Like
Reactions: ttforever
Comment

perezr10

macrumors 65816
Jan 12, 2014
1,301
560
Monroe, Louisiana
I’m now having this issue but with my left one. For whatever reason, only the right one seems to work and the left doesn’t even show up in the battery widget. The problem seems to be getting progressively worse. Today I had to forget my AirPods in the Bluetooth menu and re-pair to get the right airpod to show up.
 
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
I’m now having this issue but with my left one. For whatever reason, only the right one seems to work and the left doesn’t even show up in the battery widget. The problem seems to be getting progressively worse. Today I had to forget my AirPods in the Bluetooth menu and re-pair to get the right airpod to show up.
I still don’t know weather to turn mine in to Apple or not. My pods are now working but with countless of issues. NC has taken a massive hit and the sound even on maximum is a lot lower. Also I get fuzzy Noises and sounds in one pod. Also the left pod seems to be louder than the right one. This is not the product I paid for. Just want them to work how they did when I first used them from out the box. Really don’t know weather to hold out for a software update that hopefully will fix the issues or just turn them in to Apple. This is really annoying and really don’t know what to do.
 
Comment

bwinter88

macrumors regular
Jul 20, 2012
140
1,887
I had this issue as well, my right bud was not responding. The solution was to put them back into the case, forget the Bluetooth pairing and then re-pair them using the button on the back of the case.
 
Comment

John dosh

macrumors regular
Original poster
Oct 22, 2019
195
118
I had this issue as well, my right bud was not responding. The solution was to put them back into the case, forget the Bluetooth pairing and then re-pair them using the button on the back of the case.
That does not solve the downgrade in quality of sound which is the problem.
 
Comment

bwinter88

macrumors regular
Jul 20, 2012
140
1,887
That does not solve the downgrade in quality of sound which is the problem.
I re-read your post, it's pretty clearly a hardware issue, why not just raise the issue with Apple support? They're virtually guaranteed to swap them out with a new pair.
 
Comment

PeterRollback

macrumors regular
Mar 3, 2015
218
63
Arizona
If you haven’t done so already, unpair and repair them. Also perform an ear tip test just in case its not sealing with your ear canal.
If you have t go to Apple, they wont have to ship them out. Simply replace them (assuming they have them).
 
Comment

SemAms

macrumors newbie
Sep 19, 2011
1
0
someplace very hot
My airpod pros were working fine for the first 3-4 weeks and then the right airpod started to fail; it would not register and ANC would automatically switch off. I resorted to the procedure on apple website that is unpairing and resetting the airpods. When the issue started repeating itself every day, I went to apple and been advised to return them (they did not have replacement available so gave me credit instead) I had been told it was a known hw issue
 
Comment

j0nblayz

macrumors 6502
Jul 21, 2007
256
77
Same odd issues with my right buds again, exchanged my ear buds few time’s now, and the right one continual fails :( my guess there is some type of hardware issues with the right bud. Now my right one has major delays connecting to my iPhone, or sometimes doesn’t even play any sound even though I can hear that ANC is enabled or transparency is on. Bit tired of exchanging and having same odd issues, luckily got AppleCare so I’m gonna wait it out until they update their hardware (hopefully)
 
Comment

Bbafett

macrumors 6502
Sep 14, 2012
308
84
Georgia
I am getting annoyed with my launch day AirPod pros losing sound in my right one more than anything. It is still connected. I have forgot them in Bluetooth several times. Tried resetting the firmware and didn’t help. On the latest iOS. Problem occurs on iPad and iPhone but more on iPad since I use that more for videos.

Going to contact Apple tomorrow or Monday to see about replacement option.
 
Comment

j0nblayz

macrumors 6502
Jul 21, 2007
256
77
quick update, got a replacement set and same issue again with the right pod :(

right continually does not connect and take few tries of putting back in the case and out.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.