Apple AirPort Extreme not found by PC (windows 7)

Discussion in 'Mac Accessories' started by Krovem, Sep 23, 2010.

  1. Krovem macrumors 6502

    Krovem

    Joined:
    Feb 9, 2009
    Location:
    Indiana
    #1
    Hi everyone,

    We have been sitting here for hours trying to figure this out. Apple or HP was no help at all.

    So we just bought the Apple APE base station (refurb). We are trying to connect it to the PC (HP with windows 7). It is directly connected to the modem. The install disc was installed, now we open the Airport Utility on the PC. We scan for the APE and it does not find it.

    Now when I search for it on my Mac, it finds it with no problem. I can change all the settings and do all configs. I want to do that on the PC because it is the main computer.

    Apple said that some firewall or anti virus might be blocking it, but we turned all off.

    Please help us asap.
    Thank You so much!
     
  2. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #2
    Unfortunately, I had the same problem. I spent around 12 hours cumulatively over 2 or 3 days trying to get my Airport express to work with my PC. Without going into details, I tried EVERYTHING. I finally gave up and returned it.

    I now have my 2 Macbook Pros (I have one and my wife has one) and re-purchased an AE. It works flawlessly with the Macs.

    Sorry I don't have an answer but I think, after all the time and research I did my first time around, the AE won't work with some PCs and/or operating systems.

    For what it's worth, at one point I got my PC to see the AE but it lost the signal and I was never able to re-discover it.

    I think the whole ordeal took about 4 months off my life.
     
  3. Krovem thread starter macrumors 6502

    Krovem

    Joined:
    Feb 9, 2009
    Location:
    Indiana
    #3

    Hi, thanks for the reply! Yeah, there is nothing on google on it. I mean I am sure we are not the only once. Either people have it working or everyone gave up and returned it. We are just going to probably return it and get another brand. Thanks so much for the reply!
     
  4. ycheng macrumors newbie

    Joined:
    Jan 5, 2009
    #4
    Had the same problem before, both of my Airport Express and Extreme.
    Was OK with Mac but no good with Win7 PC with Symantec Antivirus and Firewall installed.

    After I restored PC OS and used the default windows firewall, all of these two wireless routers could be found via the Airport Tools in Win7.
     

Share This Page