Apple blocked jailbreak iphone for apps?

Discussion in 'Jailbreaks and iOS Hacks' started by aircooler, Nov 5, 2009.

  1. aircooler macrumors newbie

    Joined:
    Nov 5, 2009
    #1
    Hi

    I have jailbreak iphone (for blackra1n) but still buy geniue software from app store. Few days ago bought c&c but can install it. I get error message while installing that say , game cant be installed because iphone contects has been modificated.

    Anyone face this problem?

    Thanks
     
  2. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #2
    Holy geezums kid. Where you from?

    You may want to find a translator...
     
  3. aircooler thread starter macrumors newbie

    Joined:
    Nov 5, 2009
    #3
    Not everyone born in UK, US or any other country where english is main language.

    You don't understand my question?
     
  4. Zyniker macrumors 6502

    Joined:
    Feb 14, 2008
    #4
    Some games may perform checks in order to ascertain whether or not you purchased them. If your iPhone has been jailbroken, there is a chance it will fail those tests.
     
  5. sparrky macrumors 6502a

    sparrky

    Joined:
    Oct 23, 2008
    Location:
    California
    #5
    What is c&c? If even the legit copy won't install, then try the pirated version. It should be cracked so that it will install regardless of jailbreak or if the phone has been "modificated" :p. (before people hurl objects at me, I'm only suggesting this since he already paid for the app) ;)
     
  6. aircooler thread starter macrumors newbie

    Joined:
    Nov 5, 2009
    #6
    I don't want come back to official firmware, as o2 in UK told there is no way to unlock phone. In future i will need sim from other country in this phone.

    I have bought this game, don't want download illegal stuff so looks like i will not play in this game. Hope there will be not a lot games with checking a firmware, or o2 will start unlocking phones, even for money.

    C&C = command and conquer

    thanks
     
  7. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #7
    Can you type the error EXACTLY as you see it please?
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    Or perhaps a screenshot? I feel like I have not heard of an app refusing to install merely because of jailbreaking before....
     
  9. aircooler thread starter macrumors newbie

    Joined:
    Nov 5, 2009
    #9
    i will do in the morning (UK time), as i don't have access to my computer now and this message come out in itunes.
     
  10. Blinkwing macrumors member

    Joined:
    Sep 23, 2009
    Location:
    New Zealand
    #10
    I've heard reports of the cracked version of C&C crashing at startup. Guess the cracked version was released prematurely, or the actual app itself checks for JB strings?
     
  11. aircooler thread starter macrumors newbie

    Joined:
    Nov 5, 2009
    #11
    "the application Red Alert was not installed on the iphone because its resources have been modified"
     
  12. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #12
    Have you tried removing it from your iTunes and re-downloading it from the App Store ?
    If you're the only purchaser of the app having this issue, it may be a corrupt download.
     
  13. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #13
    Sounds like the app is checking for integrity (perhaps to make cracking more difficult?) and won't install if it detects changes to certain files.
     
  14. tadad1 macrumors 6502a

    tadad1

    Joined:
    Oct 20, 2008
    #14
    This is nothing to do with the jailbroken device. The message is due to a problem with the the app file which is failing a checksum integrity check during install, if it was downloaded from the appstore as suggested it may be corrupt and needs to be deleted and re-downloading.
     
  15. Swede macrumors newbie

    Joined:
    Oct 12, 2009
    #15
    my friend has a couple off apps that once downloaded and install, when activated bring up an error "this app does not work on jailbroken devices" im not an app whore and download as many as him so ive never come across a problem, but it is out there...
     
  16. justinwebb macrumors regular

    Joined:
    Aug 23, 2009
    Location:
    Columbus, Ohio
    #16
    i also downloaded the same game from the app store and it installed fine but when installing the map pack it wouldnt let me. I found out that it checks for appsync so i uninstalled it and it worked fine
     
  17. aircooler thread starter macrumors newbie

    Joined:
    Nov 5, 2009
    #17
    Hi

    The solution was to deactivate and activate my computer, in itunes. Game working now.

    Thanks for help.
     

Share This Page