Apple Bluetooth Mighty Mouse Not Tracking - Please Help

Discussion in 'Mac Accessories' started by Hurd111, Nov 25, 2010.

  1. Hurd111 macrumors member

    Joined:
    Oct 3, 2008
    #1
    Hello everyone,

    My Bluetooth mighty mouse isn't tracking at the moment. Not at all. Everything else (clicking, side buttons, scrolling) works fine, but the other day, for some reason it just stopped tracking. I've never had any problems with it before, so I'm a bit confused.

    I've tried everything - Cleaning battery contacts, trying multiple brands of batteries, re-setting it up as a bluetooth device, but nothing seems to work.

    I'm really confused and can't find any info on this.


    Please help!

    Thanks. ;)
     
  2. jdizzle93 macrumors newbie

    Joined:
    Nov 25, 2010
    #2
    press really hard on button

    tracking will come back vertically and horizontally. Real hard once twice and then the third time it came back yahooooooooo
     
  3. Hurd111 thread starter macrumors member

    Joined:
    Oct 3, 2008
    #3
    I'm not exactly sure what I did, if anything, but I left it on for most of the day, checking occasionally to see if it worked, and for some reason it works now.


    Weird.
     
  4. Hurd111 thread starter macrumors member

    Joined:
    Oct 3, 2008
    #4
    It's been a few months and it's happened again. Except this time it doesn't do anything at all. No clicking, no tracking, no scrolling, side buttons do not work, but it still is "connected" when I drop down my blutooth menu.

    I still need some help.
     
  5. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #5
    The no clicking, no scrolling business is not a good sign.

    But before giving up on the tracking, turn it over and make certain that there's nothing blocking the laser. I once had a mystifying tracking failure and it turned out that there was a small animal hair in the laser well - very hard to see, but just big enough to disrupt the tracking.

    If that doesn't help, then probably you've got a general hardware failure. So far as I know, the bluetooth radio can function properly when everything else isn't.
     
  6. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #6
    Have you tried removing the back and cleaning the lenses?
     

Share This Page