Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Sep 26, 2017

So, I'm trying to import a .epub file into Apple Books but sadly, this doesn't work. I've tried both dragging the .epub file into the library and importing it by going to File->Import...

CleanShot 2022-08-05 at 17.21.20@2x.png

This issue is with Apple Books Version 4.4 (5177) running on macOS 12.4 on the MacBook Pro M1 Pro. I'm wondering if it's a permissions issue.


macrumors 6502
Feb 24, 2009
Chicago, IL
This should work as long as the ePUB file doesn't have DRM applied. You should also be able to double-click the ePUB file and it should automatically open in the Books app.

Your other options that I've read about are to try using an online conversion tool and convert your original ePUB file to an ePUB file. This has worked for some. Finally, you could download Calibre (free) and convert the ePUB file to a .PDF and then import that into Books. Not as ideal, but as a last resort, it's an option.
  • Like
Reactions: KaliYoni


macrumors 6502
Mar 26, 2010
I have the same problem. I used the ibooks/books app to manage my ebooks for years, but since I had to do a reinstall and upgrade to Montery the books app does not add any files in the epub format (no DRM) anymore. It does not matter if I try to drag & drop or use import, nothing happens. This is really annoying.

Edit: Strangely, updating to 12.6 somehow did the trick, epubs can be imported again.
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.