Apple BT keyboard probs

Discussion in 'macOS Sierra (10.12)' started by MrMister111, Oct 9, 2016.

  1. MrMister111 macrumors 68000

    Joined:
    Jan 28, 2009
    #1
    Anyone have the below problem. It's here on MacOS, but I also had it on 10.11 as well so really unsure, for ref I did a fresh install of MacOS as well.

    I leave my iMac in sleep, on wakeup my Apple aluminium BT keyboard goes nuts. It types it's own characters, does as if you've pressed enter key, types in long list of characters etc without touching the keyboard at all. This is on the login screen.

    I've also done a SMC PRAM reset, as above decided to do a fresh install but still same...

    To me I've ruled out the OS, unless inherent in 2 different versions. I've replaced batteries, reset etc.

    Strange thing is if I take out the batteries of the keyboard, put back in press power it normally resets the keyboard and can go from there.

    Other time it won't, sometimes having to hold down power to force restart the iMac, not good for HDD or iMac in general really.

    So could it be the actual keyboard at fault? Or a sleep problem etc? Anyone else have this problem?

    Any other suggestions please?
    Thanks
     
  2. yellowscreen macrumors regular

    yellowscreen

    Joined:
    Nov 11, 2015
    #2
    exactly the same problem...

    i just turn the keyboard off then on again. it connects again and all is good, but definitely not a great experience

    tried deleting it from system preferences and connecting it again, same thing

    any help would be much appreciated
     
  3. MrMister111 thread starter macrumors 68000

    Joined:
    Jan 28, 2009
    #3
    Which OS? Just MacOS or also on other versions?

    I never get any problem on the Apple wireless mouse though. It's a really basic thing to not work, but is really really frustrating.
     
  4. coleblk macrumors regular

    Joined:
    Nov 26, 2013
    #4
    I have experienced this same problem for quite some time. Still running OS X 10.11 and it's unfortunate to hear it is still happening is 10.12. I tried all of the resets you mentioned as well and it does it less now, although still occasionally. Since those resets, I now have a new issue where the keyboard won't want to wake the display up...or it does rather but displays a completely black image not allowing me to login until I manually press the power button on the back. Other times it works fine, so strange and really annoying. Assuming you are also using the same keyboard as me, the first generation aluminum Apple keyboard and not the newest one with the redesigned charging port, right?

    So annoying and makes me want to go back to Mavericks where I never noticed this happening. Wondering if me and the OP's backups are corrupted or something... :/ Also, wondering what the specs are of the machine you are using? Mine is a late 2012 3.4 i7 with the fusion drive and Apple upgraded RAM.
     
  5. yellowscreen macrumors regular

    yellowscreen

    Joined:
    Nov 11, 2015
    #6
    Both 10.11 and 10.12

    Also never had issues with the mouse
    --- Post Merged, Oct 9, 2016 ---
    I'll try that, thank you!
     
  6. MrMister111 thread starter macrumors 68000

    Joined:
    Jan 28, 2009
    #7
    Mine is the 1st Gen Alu BT keyboard that you use batteries with, I made sure these are fully charged.

    I thought maybe a backup or preference file or something was corrupted so thought for 10.12 I'd do a fresh install, and hoping they'd fixed the issue. Nope even this and still no good.

    I'll also try the reset BT, please post back everyone on findings.
     

Share This Page