Apple Certificate Not Valid

Discussion in 'macOS' started by kellybow144, Apr 23, 2015.

  1. kellybow144 macrumors newbie

    Joined:
    Jan 24, 2015
    #1
    Hello Everyone,

    I noticed after I did a recent update now every time I go on a website on Safari it gives a error that the apple certificate is not valid. It pops up every time and you can press continue but it doesn't display the page. Also I tried using Firefox and Chrome and it does the same thing. Also when i open iTunes it says "The certificate for this server is invalid. You might be connecting to a server that is pretending to be “init.itunes.apple.com”, which could put your confidential information at risk. Would you like to connect to the server anyway? " Can anyone please help with this? Thank you!
     
  2. jorgk macrumors member

    jorgk

    Joined:
    Mar 20, 2013
    #2

    Check this discussion https://discussions.apple.com/thread/6984765. The solution of Linc is good, if you follow it to the point (Step 5).
    Some have just downloaded the update itself (from Apple, Security Update 2015-004) and re-run it and report that it solved their problem.
     
  3. kellybow144 thread starter macrumors newbie

    Joined:
    Jan 24, 2015
    #3
    Thank you jorgk, deleting the certificates didn't work but i found out that resetting the keychain could solve it so I did that and it worked!
     

Share This Page