Apple Cinema display detected but not powering up

Discussion in 'Mac Basics and Help' started by O and A, Jun 20, 2012.

  1. O and A macrumors regular

    Joined:
    Jul 22, 2002
    Location:
    New York City
    #1
    I have an Apple HD Cinema Display 23 inch connected to a Mac Pro with another 23 inch cinema display. They are both the older aluminum HD displays.

    One cinema display fails to turn on. No LED light indicator and no image at all. Not even if i shine a super bright light into it. ( I did this to check if the back light was the issue)

    I swapped the power bricks and same issue. The same cinema display fails to power up. The working cinema display works with either power brick.

    I tried different DVI ports and different machine. Same result. Computer Always detects second display but display does not work.

    Any ideas what is broken inside? Wondering if its worth getting repaired or not.
     
  2. Paratel macrumors 6502

    Paratel

    Joined:
    Jan 26, 2005
    Location:
    Somewhere in the US
    #2
    Had a similar issue as I have 2 20 inch displays. One wouldn't come on at all. turns out is was my video card that went bad. One DVI input worked and the other did not. I swapped the two monitors connection to make sure that was it and not just a failed display.

    Although in your case sounds like it's hosed.
     
  3. O and A thread starter macrumors regular

    Joined:
    Jul 22, 2002
    Location:
    New York City
    #3
    Yeah I've tried it on several Mac pros ands book pros and no luck.
     

Share This Page