Apple.com slow?

Discussion in 'Current Events' started by mac-fan, Dec 28, 2007.

  1. mac-fan macrumors newbie

    Joined:
    Dec 28, 2007
    #1
    I've had issues bringing up the apple.com website over the past couple of hours (currently 1:30 PM EDT)...what normally takes less than 10 seconds is taking 5 to 10 minutes or more...software update has not responded...

    Access to other websites is fine...

    Anyone else experiencing this?
     
  2. psycoswimmer macrumors 65816

    psycoswimmer

    Joined:
    Sep 27, 2006
    Location:
    USA
    #2
    I just went through and it's working fine for me.
     
  3. mac-fan thread starter macrumors newbie

    Joined:
    Dec 28, 2007
    #3
    Thank you for checking...speed is a little better now, but still slow compared to normal...it was horrible a while ago...probably all of the new users updating their software or perusing the support forums...

    Thank you again...
     
  4. mac-fan thread starter macrumors newbie

    Joined:
    Dec 28, 2007
    #4
    Still seems to be an issue with Software Update... or some of the support or download links...I'm sure it will clear up eventually...
     
  5. GSMiller macrumors 68000

    GSMiller

    Joined:
    Dec 2, 2006
    Location:
    Kentucky
    #5
    It's no slower than usual for me. The search function is actually working pretty good today, it' usually pretty slow.
     
  6. mac-fan thread starter macrumors newbie

    Joined:
    Dec 28, 2007
    #6
    Sorry, this turned out to be an issue with Safari...Firefox worked fine. After using the Reset Safari option it's working fine again...strange...all other sites worked fine...just anything with apple.com was very slow...oh well..

    Thank you for the feedback...
     

Share This Page