Apple/Command+S not working!

Discussion in 'Mac Basics and Help' started by mersea, Sep 2, 2008.

  1. mersea macrumors regular

    Joined:
    Mar 28, 2005
    #1
    Just today I realized that apple + s isn't saving in ANY program. There is obviously no problem with either key on their own, s works fine and I can apple + pretty much everything else...

    Affected programs:
    - MS Word
    - Burn (financial freeware)
    - Camino
    - etc

    I have my keyboard viewer open, and both the command and s keys are registered as being pressed when I press them, there is just no reaction in the program. If I go to Edit > Save to save manually, it still shows the shortcut keys to be cmd + s...

    Odd? Annoying!
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Are you by chance using an odd Keyboard layout (as I know there are some that have the keys behave one way normally, and another when the command key is pressed).

    Alternatively, have you tried restarting or repairing permissions?

    TEG
     
  3. mersea thread starter macrumors regular

    Joined:
    Mar 28, 2005
    #3
    Already tried both, no cigar.

    On good ol' Canadian English layout, same I've been using since I got the computer!
     
  4. vandozza macrumors 6502a

    vandozza

    Joined:
    Jun 14, 2006
    Location:
    Australia
    #4
    you could try going to system prefs/keyboard and mouse/kb shortcuts, and checking the keyboard shortcut settings there. and maybe a "restore defaults" here wouldn't hurt (if you aren't going to lose custom bindings.)
     
  5. mersea thread starter macrumors regular

    Joined:
    Mar 28, 2005
    #5
    No such luck with restoring keyboard defaults... I even added a "New Application Shortcut > All Applications > Save cmd+S" and it didn't work

    Edit:
    Futher digging brings up this thread. Yes, it is working on the other user account (which is used solely for iTunes, syncing my sister's iPod).
    Quitting quicksilver doesn't help.
     
  6. mersea thread starter macrumors regular

    Joined:
    Mar 28, 2005

Share This Page