Apple Diagnostics won't run on MacBook

Discussion in 'MacBook' started by EedyBeedyBeeps, Mar 31, 2016.

  1. EedyBeedyBeeps macrumors newbie

    EedyBeedyBeeps

    Joined:
    Jan 2, 2013
    Location:
    USA
    #1
    I have a 2015 12" MacBook. I've tried booting and holding D--and in addition to that I've tried option-command-D, option-D, and command-D. Nothing has happened other than normal boot-ups to the password screen, then nothing has happened after I've entered my password other than normal boot-ups. Nothing has been connected to my MacBook other than the power supply that came with it (and I've also tried all these holding-D iterations while disconnected from power).

    I've also tried these with my iOS devices powered off, just in case the wifi syncing has something to do with it. Nada.

    Have I missed something or have I done something incorrectly?

    (I've been trying to figure out if there's something wrong with the MacBook's battery by using Apple Diagnostics. I'm not sure if that's the proper tool...)

    Thanks for any input/help that y'all can provide!
     
  2. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #2
    Just tried it on mine and it seems to work. It's not what I've seen on my prior macs though (2011/2012)

    Powered the system off, the tapped the power button and
    when it sounded the chord I held down the D key until I saw a mouse pointer appear (white on black creen). It then displayed a list of languages to choose from, and after choosing English it showed a white text on black background "Checking Your Mac" screen with a progress bar. In a few minutes it finished and stated it hadn't checked the power adapter since it wasn't connected (it isn't).

    What do you suspect is wrong with your battery?
     

Share This Page