Apple Discussions site not working

Discussion in 'Mac Basics and Help' started by RestUnknown, Feb 25, 2018.

  1. RestUnknown macrumors regular

    Joined:
    Aug 25, 2011
    #1
    Not really sure where to post this thread.

    For over several months now, the apple discussions site is not working for me.

    I can search for threads via google and can read them, but when I sign in I get the error that the site has "redirected me too often". It advices me too delete my cookies and try again, but of course to no avail.

    Other browsers or another os doesn't work.

    Solution?
     
  2. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    The Apple Public Discussions Forums supposedly will allow you to join with your Apple ID and Password. However, if you had joined before with a different userid and password it will give you the error message you're receiving. Can you actually sign in or does it reject you all together?
     
  3. RestUnknown thread starter macrumors regular

    Joined:
    Aug 25, 2011
    #3
    I don't know if I can sign in, as I just get the error message and I can do nothing.

    I did not join before with another ID, I only have one.
     
  4. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #4
    OK, it sounds like you're being rejected and not allowed to sign in. I've run across other folks with the same problem in another forum that I'm a member of and it seems that the only cure is to keep trying until it lets you become a member. If you're using your Apple ID and password, try creating another user name (not Apple ID) and password to register and see if it lets you join that way.
     

Share This Page

3 February 25, 2018