-BigMac-

macrumors 68000
Original poster
Apr 15, 2011
1,922
1,762
Melbourne, Australia
So I've reported it every single beta. 9 betas later

Try for yourself.

Open 2 tabs in Safari.
Select the other tab, then select the original tab. As soon as that happens the 'X' button on the tab disappears.

It's still clickable, but it's invisible - a bug.

You have to hover the mouse off the tab, then select it and it becomes visible.

Really annoying. Apple doesn't care. That is all xD
 

LlamaLarry

macrumors regular
Oct 6, 2008
121
25
Northern VA
Maybe I am just not getting the steps to reproduce.

1. Open Tab A
2. Open Tab B
3. Select Tab A
4. Select Tab B
5. Something happens

For me the X only appears when hovering over the tab and is invisible on all tabs otherwise, does not matter how many tabs I have open, no X's are on the left edge of the tab until I hover over any part of the tab.
 

MarkC426

macrumors 68000
May 14, 2008
1,818
654
UK
That actually sounds like a feature, to streamline the interface.
Writing this on my iPad and it has the same effect, only current tab shows x.
 
  • Like
Reactions: LlamaLarry

MarkC426

macrumors 68000
May 14, 2008
1,818
654
UK
Ah yes, just re-read the op.
By going back to first tab (as current) x is invisible by sounds of it.
My bad..... 🤪
 
  • Like
Reactions: -BigMac-

Monotremata

macrumors regular
Apr 11, 2019
188
78
Ontario, CA
Mine pops up whenever I hover over the tab period even if Im at the opposite end. Seems like its working fine here, unless its supposed to always be visible.

Is the OP saying he has to hover OFF of the tab and it pops up? Mine go away unless Im somewhere on the tab so yeah, probably a bug going on with something over there, cause here it works fine.
 
  • Like
Reactions: LlamaLarry

chkwong

macrumors member
Jan 17, 2020
81
20
some other bugs

1. Music app: fast forward keyboard shortcut not smooth
2. Playing music in music app and airplay to Apple TV at the same time, there is dropout after few minutes
3. cannot show seconds in menu through language/region setting


other problem
1. Homebrew: some brew app cannot run in Big Sur , e.g. YouTube-dl
2. Purge-wrangler: cannot boot into macOS if csrutil reenabled after patching
 

-BigMac-

macrumors 68000
Original poster
Apr 15, 2011
1,922
1,762
Melbourne, Australia
I don't believe it's a bug. When the curser comes close to the area where the "x" resides it pops back into view - like magic👍

Lou
I'm going to screen-cap it I think. When you move from Tab to Tab, and don't un-hover from the selected tab, the X isn't visible :)
 

chkwong

macrumors member
Jan 17, 2020
81
20
Youtube-dl doesn't even open or is a matter of putting the websites inside quotation-marks?
Code:
youtube-dl "website"

I'm also asking because I use youtube-dl quite often.
I could not even brew install YouTube-dl in Big Sur
 

Wowfunhappy

macrumors 65816
Mar 12, 2019
1,153
1,377
1. Homebrew: some brew app cannot run in Big Sur , e.g. YouTube-dl

Fwiw, there are a million ways to install youtube-dl, you don't need homebrew and I'd be shocked if it was truly broken. It's a python app, and it's compatible with the still-built-in python2, even.

Download the precompiled binary from their website, or create a python virtual environment and install youtube-dl with pip.
 

chkwong

macrumors member
Jan 17, 2020
81
20
Fwiw, there are a million ways to install youtube-dl, you don't need homebrew and I'd be shocked if it was truly broken. It's a python app, and it's compatible with the still-built-in python2, even.

Download the precompiled binary from their website, or create a python virtual environment and install youtube-dl with pip.

thanks for info
Try it soon
 

-BigMac-

macrumors 68000
Original poster
Apr 15, 2011
1,922
1,762
Melbourne, Australia
no 'X' on selected tab, even while hovering over the 'X' area. Clicking on that area still 'clicks' the invisible X.

tempImageXaj4ny.png
 
  • Like
Reactions: Wad12355

ghboard2010

macrumors regular
Aug 7, 2010
150
84
Somewhere
So I've reported it every single beta. 9 betas later

Try for yourself.

Open 2 tabs in Safari.
Select the other tab, then select the original tab. As soon as that happens the 'X' button on the tab disappears.

It's still clickable, but it's invisible - a bug.

You have to hover the mouse off the tab, then select it and it becomes visible.

Really annoying. Apple doesn't care. That is all xD
Its' not a bug, its' a feature 🤫
 
  • Haha
Reactions: mcapanelli

ghboard2010

macrumors regular
Aug 7, 2010
150
84
Somewhere
Maybe I am just not getting the steps to reproduce.

1. Open Tab A
2. Open Tab B
3. Select Tab A
4. Select Tab B
5. Something happens

For me the X only appears when hovering over the tab and is invisible on all tabs otherwise, does not matter how many tabs I have open, no X's are on the left edge of the tab until I hover over any part of the tab.
I get this as well, Safari 14(15610.1.28.1.9, 15610) in the context of macOS 10.15.7
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.