Apple EFI Rom for Geforce GTX 780M

Discussion in 'iMac' started by DriveSlow, Aug 28, 2014.

  1. DriveSlow macrumors newbie

    Joined:
    Aug 3, 2014
    Location:
    Germany
    #1
    Hey guys, i recently upgraded my iMac 27" 2010 model with a Geforce GTX 780M card. It works like a charm, but i lost my boot screen.

    Now i'm thinking about Flashing the EFI part to the BIOS rom chip but I didn't find any tutorials.

    I have access to an iMac 27" 2013 with the 780M running. So, I could use the EFI part of this card to flash my own, but as I told, I don't know how.

    FYI: I did a normal nvflash already and it worked, but nothing with EFI.

    Thx in regards.
     
  2. Npalamidis macrumors newbie

    Joined:
    Jun 26, 2007
    Location:
    Venezuela
    #2
    Hello @driveslow,

    Did you manage to get the 780M flashed with the imac EFI? Today I installed my card and it was working like a charm until I installed Yosemite beta 4 and it stopped working, I now can only access using screen sharing. My display is black all the time.

    Please let me know if you have any suggestions.
     
  3. DriveSlow thread starter macrumors newbie

    Joined:
    Aug 3, 2014
    Location:
    Germany
    #3
    Sorry for the late answer. No, I wasn't able to flash my card. But sometimes I got the same issues like you. Did you installed the Nvidia Driver for OS X?
     
  4. RobertArrington macrumors newbie

    Joined:
    Feb 24, 2015
    Location:
    New Jersey
    #4
    DriveSlow, were you able to find a dumped ROM for the 780M? I can't find one anywhere.
     
  5. mhren macrumors newbie

    Joined:
    Oct 19, 2014
    #5
    I know this is an ancient thread -- but with the failing graphics cards in the 2011 iMacs a 780M may be a great option .... especially if the ROM can be updated with the 2013 GTX 780M Mac version. Di you guys ever get a rom image pulled from your 2013 iMac ?
     

Share This Page