Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

lambo13

macrumors member
Original poster
Nov 11, 2009
30
4
Have an Apple Watch Series 4 connecting to an Apple TV HD. Connects great, workouts start and I'm into it. Then it disconnects randomly. Has happened three times between yesterday and today, seemingly at random intervals. Sometimes I can finish a workout without disconnection, other times it happens a few minutes in.

Anyone else experiencing this type of disconnecting behavior? And if so, any thoughts on how to fix it?

Annoyingly, when it disconnects, you can't simply reconnect and resume your workout, because that would make too much sense. Even worse, when you reconnect the watch and restart the video you can't fast forward to where you left off!

Maddening. And so, so frustrating for a service that seems to be so otherwise highly polished.
 

jakespeed

macrumors member
Jul 22, 2002
90
71
I definitely experienced this on a treadmill workout. At the same time, I noticed that my HR, distance etc didn't match the screen...then after a few minutes...it will disconnect. Seems promising but I couldn't even finish the first workout. I suspect it MAY be the distance from my tv to treadmill or that I was using AirPods connected to the AppleTV at the same time.

Also noticed it had a tuff time getting started...kept auto-pausing.
 

lambo13

macrumors member
Original poster
Nov 11, 2009
30
4
I definitely experienced this on a treadmill workout. At the same time, I noticed that my HR, distance etc didn't match the screen...then after a few minutes...it will disconnect. Seems promising but I couldn't even finish the first workout. I suspect it MAY be the distance from my tv to treadmill or that I was using AirPods connected to the AppleTV at the same time.

Also noticed it had a tuff time getting started...kept auto-pausing.
That's interesting - I also had AirPods connected to my AppleTV as well. Wonder if that's a factor.

In my case the distance wasn't an issue. I moved the Apple TV out in the open in front of our tv, just a few feet from where I was lifting.

I did however just do another workout but using Fitness+ on my iPad and it maintained a solid connection throughout.

Still can't believe they don't offer a resume function or the ability to fast forward through a workout. Seems insane.
 

jakespeed

macrumors member
Jul 22, 2002
90
71
Maybe I will try it from my phone and cast next time to see how that works. Could then pair my AirPods to the TV to listen.
 

charlien

macrumors 6502
Jul 3, 2006
266
53
I definitely experienced this on a treadmill workout. At the same time, I noticed that my HR, distance etc didn't match the screen...then after a few minutes...it will disconnect. Seems promising but I couldn't even finish the first workout. I suspect it MAY be the distance from my tv to treadmill or that I was using AirPods connected to the AppleTV at the same time.

Also noticed it had a tuff time getting started...kept auto-pausing.
I got disconnected this morning on my first try. I was wearing Powerbeats pro headphones. Maybe you found something.
 
  • Like
Reactions: lambo13 and ApeBot

sammjordan

macrumors regular
Sep 23, 2009
144
44
I had the same issue yesterday, my watch was connected to an ATV HD, about 20 mins into a 30 min HIIT workout it disconnected. The last ~5 mins of the workout my activity data wasn't in sync with what was actually on my watch. Super frustrating bc I couldn't resume the workout! I had AirPods connected to my ATV as well. I'm going to try it with my ATV 4K and see if that makes a difference
 
  • Like
Reactions: lambo13 and ApeBot

Philstuman

macrumors member
Nov 26, 2020
30
10
Sydney, Australia
Interesting, this just happened to my wife 20 min into a 30 min strength workout. She didn't have any bluetooth headphones connected, but perhaps the distance to the appleTV is too much...
 
  • Like
Reactions: lambo13

cknibbs

macrumors 6502
Dec 12, 2012
288
830
This also happened to me. Series 4, Apple TV, and AirPods Pro connected to the ATV. Literally 5 feet away from the ATV. They need a quick fix of implementing a resume option, and then to address the issue permanently IMHO.
 
  • Like
Reactions: lambo13 and ApeBot

mattster16

macrumors 6502a
Apr 18, 2004
743
489
Had this happen yesterday, so frustrating to put in 20 min+ of hard effort and then not be able to finish the workout! Had my AirPods connected to the ATV.
 
  • Like
Reactions: lambo13 and ApeBot

Drababan

macrumors member
Sep 22, 2016
47
24
I guess i feel lucky. I have 2 series 5 AWs that i rotate every day. I've run treadmill runs each day with AirPods Pro attached to ATV and haven't had any issues. How close is your ATV to your treadmill? Mine is right next to it on a shelf, not behind the TV or anything like that.
 

Traderman09

macrumors newbie
Dec 15, 2020
6
2
Most of my workouts have ended suddenly midway through with the “device connection lost” message. The workout ends on both the Apple TV (HD) and my watch (series 6)

It seems as though the connection drops out a while before (heart rate and calories stop updating on the Apple TV but continue live on the watch) but after 5 or 6 minutes I get the dreaded “device connection lost” screen and am left sweaty and irritated.
 
  • Like
Reactions: lambo13 and ApeBot

agsmith87

macrumors newbie
Aug 1, 2012
14
3
Adelaide, Australia
I’ve had this too.
Similar things through all the posts above (and elsewhere: reddit/Apple Support)
  • AirPods or Powerbeats connected
  • TV HD (4th gen)
Can anyone confirm if they’ve had the issue without one or both of these?
 

ApeBot

macrumors regular
Oct 15, 2015
105
199
Sydney
I had the same issue yesterday, my watch was connected to an ATV HD, about 20 mins into a 30 min HIIT workout it disconnected. The last ~5 mins of the workout my activity data wasn't in sync with what was actually on my watch. Super frustrating bc I couldn't resume the workout! I had AirPods connected to my ATV as well. I'm going to try it with my ATV 4K and see if that makes a difference
Exactly the same scenario here except on a treadmill. I thought it was a distance issue so I moved the ATV closer to my treadmill but it happened again. Distance is about 2m between arm and ATV and it always seems to die at the 20 minute mark. It’s driving me nuts and I end up going back to my iFit workout.
 

ApeBot

macrumors regular
Oct 15, 2015
105
199
Sydney
I guess i feel lucky. I have 2 series 5 AWs that i rotate every day. I've run treadmill runs each day with AirPods Pro attached to ATV and haven't had any issues. How close is your ATV to your treadmill? Mine is right next to it on a shelf, not behind the TV or anything like that.
I think you are lucky. Personally, I’m not about to redesign my house around technology that doesn’t work. Six feet should be close enough. I’ve completed all my one hour runs with AirPod Pro connected to the ATV with no issue. The fact that this always happens at the 20 minute mark tells me it’s something else.
 

andylel

macrumors member
May 12, 2015
46
36
This has happened to me with series 4 watch connected to Apple TV 4K, nothing else connected and watch within 5 ft of Apple TV at all times.
 

FuzzyDicePHL

macrumors newbie
Nov 2, 2013
24
6
This has happened to me while using F+ on ATV with Watch Series 5 and 6, with and without Power Beats Pros, but only on workouts with more active content. EG: Disconnected during treadmill and rowing workouts, but not yoga or core workouts. SO frustrating.
 

jxpx777

macrumors newbie
Feb 23, 2005
7
20
I was having this issue a lot. Then today, I completed my first workout on the Apple TV. The only thing that changed was I connected my Apple TV to Ethernet! There’s a thread on Reddit about trying to suss out this issue too.
 
  • Like
Reactions: lambo13

jakespeed

macrumors member
Jul 22, 2002
90
71
Just wanted to confirm that for me the connection also died right around the 20 minute mark. I did attempt another treadmill workout yesterday and managed to get through without the headphones connected...however it DID keep auto-pausing on me around the same time frame. After that it continued on without any trouble.

For now, I'm headed back to Peloton....hopefully it improves soon.
 
  • Like
Reactions: lambo13

wpalomine

macrumors member
Oct 22, 2010
76
36
Disconnects on Spin, Yoga, HIIT and Strength workouts with AW6, ATV and AirPod Pros. However, workouts complete with AW5 and ATV 4K.
 
  • Like
Reactions: lambo13

dodghyhair

macrumors newbie
Dec 23, 2020
3
3
Same problem with me - 'Device lost connection' comes up randomly during workouts with AW3, ATV and AirPod Pros. Have spoken to Apple (they didn't seem to think this was a recognised issue) who suggested unpairing and re-pairing my watch with my phone. I'm not convinced this will work so will try workouts with iPad first to narrow down the issue.
 
  • Like
Reactions: ApeBot and lambo13

CircleMeetsSquare

macrumors newbie
Dec 28, 2020
1
1
This happened to me three times today, a few mins into a 10 minute workout, 10 mins into a 30 minute workout, and about 7 minutes into a 20 minute workout. I also had my airpods connected to the TV. Will try next time no airpods and see if that fixes the issue.
 
  • Like
Reactions: ApeBot
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.