Apple forcing iPhone users!


eawmp1

macrumors 601
Feb 19, 2008
4,130
5
FL
1) STOP SHOUTING IN YOUR TITLE
2) Get over it, my old PPC iMac cant run Snow Leopard. Some of my desktop apps don't run in older software versions. Technology advances. Progrmas/features dot always support legacy code. If you MUST have a new app, update your iPhone system software. But Apple isn't "forcing" you to do anything.
 

blancoBronco

macrumors 6502a
Jul 4, 2009
726
29
South Tampa
Ya might want to look up the word force.


why are iphone users so whiney?
whoa, don't lump us all with the OP. I upgraded to 3.1 the day it came out.

and OP, why does it matter that you have to upgrade to 3.1? apple would only release an update if it would improve on the last one
 

amorya

macrumors 6502
Jun 17, 2007
252
7
That is an incorrect statement. Yelp's augmented reality works perfectly in 3.0.

They just chose to make the app 3.1 compatible... it's totally up to the devs.
Actually, you're wrong. Apple introduced a bunch of augmented reality APIs in 3.1. There were no previously available augmented reality APIs.
 

wingsabr

macrumors 6502
Dec 13, 2008
449
11
I could quote so many but mostly everyone hit the nail on the head. You want new feature, upgrade. Apple is forcing anyone to do anything...
 

gloss

macrumors 601
May 9, 2006
4,811
0
around/about
Regardless, I have 3.0 installed and am using Yelp's augmented reality just fine.
Yelp's app used undocumented APIs and so was in violation of the SDK agreement, though Apple seems to have let it slide. The actual, documented, legitimate AR APIs, which these apps are using, are in 3.1.
 

ViViDboarder

macrumors 68040
Jun 25, 2008
3,447
0
USA
There have been OS requirements for a long while now... I'm pretty sure 2.X can't run all the apps in the apstore either. :p
 

billchase2

macrumors 68000
Feb 28, 2006
1,801
91
Ann Arbor
Yelp's app used undocumented APIs and so was in violation of the SDK agreement, though Apple seems to have let it slide. The actual, documented, legitimate AR APIs, which these apps are using, are in 3.1.
Interesting, I didn't realize that. Thanks for the info!
 

iceterminal

macrumors 68000
May 25, 2008
1,868
27
Dallas Tx.
Did Apple make the app? No. So how is Apple making you upgrade?

Please, THINK. Because when people make statements as such....well it makes them look really stupid. Really.
 

Clete2

macrumors 65816
Sep 20, 2008
1,069
24
USA
So just update to 3.1? 3.1 and > support augmented reality. Just re-jailbreak..

Jailbreaking isn't officially supported, so how could you expect to not have to redo your settings? Nothing that isn't supported will be as easy to do as those things that are officially supported.
 

AbSoluTc

macrumors 601
Sep 21, 2008
4,337
2,617
No one is forcing you to do anything. Dont upgrade: dont get app. The app needs the new software to work.
I agree.

Seems no matter what happens, people are going to bitch. All about the smallest and most petty things. Next we will be hearing about how some apps are not available for the 3G. Then they become available and they now whine that they are slow and unusable.

Gee, I WONDER WHY?:rolleyes: