Apple Global Service Exchange (GSX) help with CSD

Discussion in 'Mac Basics and Help' started by Monkeyat, Jun 19, 2012.

  1. Monkeyat, Jun 19, 2012
    Last edited: Jun 19, 2012

    Monkeyat macrumors regular

    Joined:
    Feb 14, 2009
    #1
    I have a mid-2009 13" MacBook Pro and suddenly my wifi card has disappeared :( Both Hardware profile and Network option doesn't show a wifi card anymore.

    So, I've found a Clamshell Service Diagnostic (CSD) installer to help me to make a diagnostic of the problem without opening my computer. When I try to install the CSD utility into a Transcend USB key (8Gb) it seems that the process runs well BUT after it's finished the USB key is intact ! I've already tried to partition the key with MBR and GUID tables but no luck.

    Here are some screenshots :
    [​IMG]
    [​IMG]
    [​IMG]

    Does anyone have access to Apple Global Service Exchange (GSX) in order to search some help for me, please ?

    TIA,

    M.
     
  2. Obstfreak38 macrumors newbie

    Joined:
    Jun 22, 2012
    #2
    Hi Monkeyat,
    you need the following tool to check your book (the CSD-Tool is the wrong one): Apple Service Diagnostic 3s132.
    I hope this helps.
     
  3. Obstfreak38 macrumors newbie

    Joined:
    Jun 22, 2012
    #3
    hi
    it´s me again. I found the "CSD Read Me.pdf" with instructions how to use the diagnostic tool. I hope that it is what you are looking for.
     
  4. Monkeyat thread starter macrumors regular

    Joined:
    Feb 14, 2009
    #4
    Thanks! But I have the readme with CSD. The problem persists :(
    I'd like to know if there are other instructions or help at Apple site...
     
  5. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #5
    Have you tried booting to a base OS on an external drive? issue still persist?

    Could be possible the cables have become slightly loose causing the issue.
    You'll have to remove the clutch cover to check the airport cables not just the antenna's but the airport connector as well.
     
  6. Monkeyat thread starter macrumors regular

    Joined:
    Feb 14, 2009
    #6
    Thanks, but finally I've decided to send it for maintenance... I'll post the results next week! I hope I can get the WiFi back :confused:
     

Share This Page