Apple Hardware Test: does it test the optical drive?

kant

macrumors 6502
Original poster
Jul 22, 2004
337
0
Because I've discovered that my NewToMe/used powerbook's combo drive won't read cd-rs. But it will read pressed cds/dvds and dvd-rs. So I ran the AHT and it doesn't acknowledge the combo drive's existence. (Ran the AHT after repairing permissions, fsck, PRAM.) This is only my second mac and I never had any problems out of the ibook, so I've never seen the AHT screen until now and don't know if it tests the optical. :confused:

12"pb
1ghz
1.25mb
40gb hd
combo drive
AE and Bluetooth

Edit: And I'm relatively certain that the problem isn't the OS - it can read the same cd-rs when using a dvd-burner in a firewire enclosure.
 

CanadaRAM

macrumors G5
OK I'll bite.

You ran AHT from the CD, correct?
Does it ask you to put in a different CD or a blank? No? Then all it can possibly test is the ability to read from the Hardware test CD itself. So for your purporses, no it can neither confirm nor deny that the optical drive will work with other media.
 

kant

macrumors 6502
Original poster
Jul 22, 2004
337
0
CanadaRAM said:
OK I'll bite.

You ran AHT from the CD, correct?
Does it ask you to put in a different CD or a blank?
DVD actually. So the AHT doesn't test the drive at all and I shouldn't see a window in the hardware section showing the stats on the drive??

In that case...

is the fact that the drive won't read CD-Rs a hardware or software issue???? And what the he** do I do about it?

The situation is really starting to annoy me. I just installed the drivers and programs for my Epson RX500 from the factory cd. Worked just fine. But any CD-R, be it data or audio, it treats as a blank.
 

Norouzi

macrumors 6502
Aug 6, 2004
395
14
Philadelphia, PA
I'm just throwing this out there, but I've seen older CD burner's not read specific speeds and types of disks. I put an old CD burner in a friends computer and tried to install some drivers off a new memorex 52X CD-R and the disk wouldn't even read. All the other disks I tried worked fine just not thoes disks.

Are the CD-R's your trying all the same speed and brand, or are they different? That's all I've got.