Apple hardware test on mid 2012 15" MBP

Discussion in 'MacBook Pro' started by thiswho, Feb 21, 2013.

  1. thiswho, Feb 21, 2013
    Last edited: Feb 21, 2013

    thiswho macrumors member

    Joined:
    Oct 11, 2012
    #1
    Hi all,
    I decided to run the AHT, just to make sure everything is running smooth (I had to have the Crucial RAM replaced when i first got the computer because it threw an error code and kept giving me kernel panics) and I cannot seem to get through the basic test. I haven't been having any kernel panics, but safari froze up and crashed once, which freaked me out a little so I decided to run the test.

    I cannot get the test to go past 11 seconds. It displays "testing memory", and the just locks up. I can still move the mouse pointer, and click "stop" but it doesn't do anything. I've left it for quite some time and it just doesn't unstick itself. I've also tested the Apple ram, and it wouldn't complete.

    Right after I got the RAM replaced, I ran the test and the memory checked out OK. I also checked the Apple RAM before I put the Crucial in and it worked too.

    A few months later, I ran the tests again, both on the Crucial RAM and the Stock APPLE ram, and I could only get the test to complete once.

    Basically, do I have a problem with the computer or the RAM? Or is it common for the AHT to just.... not work? it's kinda bugging me, but not really a big deal since the computer runs fine. Just wondering if anyone else is having this problem?

    is it something worth bringing to the genius bar?
    side note- I ran Rember, and it didn't pick up any memory errors. Why wont AHT complete?!
     
  2. Adomas macrumors newbie

    Joined:
    Mar 4, 2013
    #2
    Here the same, just created new thread http://forums.macrumors.com/showthread.php?t=1552035
     
  3. Risco macrumors 68000

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
  4. Giuly macrumors 68040

    Giuly

    #4
    It takes a while to test 16GB of RAM. Let it run overnight.
     
  5. Risco macrumors 68000

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #5
    Running the quick test?
     

Share This Page