Apple has stopped signing 5.0.1

Applejuiced

macrumors Westmere
Original poster
Apr 16, 2008
40,652
6,404
At the iPhone hacks section.
Apple has ended the window for installing iOS 5.0.1 on your iPhone, iPad, or iPod touch.
A5 devices are now immovable from iOS 5.1 if they have been updated until a solution for downgrading can be found. SHSH blobs will not do you any good for downgrading an A5 device at this time.
Be extra careful not to "accidentally" update to 5.1 on an A5 device.
A4 devices with saved blobs can still be downgraded as usual.
 

Minhimalism

macrumors 6502a
Jan 6, 2012
997
141
Texas
how do we know what would cause this issue?
We don't, really. Just avoid installing dated packages, cracked applications, cracked tweaks, etc. While I know a lot of people still will and many will run just fine, there are always possibilities of compatibility issues. Feel free to install how you like, just be very wary!
 

F123D

macrumors 68040
Sep 16, 2008
3,775
16
Del Mar, CA
I usually search for reviews or look for videos on youtube of the tweak (and read the comments) before I install something new. Better safe than sorry.
 

TheVille

macrumors newbie
Mar 10, 2012
2
0
Does this mean I cannot update to 5.0.1. by any mean? I tried to recover to 5.0.1. IPSW today with itunes and tried every trick, recover mode, pwned DFU and everything i know of, but couldn't do the update (got error message 1394 if i remember right). I'd like to update to ios 5 and then jailbreak, but is it possible atm?
 

rgarjr

macrumors 603
Apr 2, 2009
6,473
313
Southern California
Does this mean I cannot update to 5.0.1. by any mean? I tried to recover to 5.0.1. IPSW today with itunes and tried every trick, recover mode, pwned DFU and everything i know of, but couldn't do the update (got error message 1394 if i remember right). I'd like to update to ios 5 and then jailbreak, but is it possible atm?
Are you on a iPhone 4 or 4s? The OP mentioned that it should be no problem on A4 devices as long as you have saved blobs for them.
 

TheVille

macrumors newbie
Mar 10, 2012
2
0
Actually i'm on 3gs ... And I've jailbroken previously to 4.3.3. I have the 5.0.1. IPSW file, though it just won't install.
 

NanoNyrd

macrumors regular
Dec 1, 2011
218
0
Actually i'm on 3gs ... And I've jailbroken previously to 4.3.3. I have the 5.0.1. IPSW file, though it just won't install.
If you have saved SHSH blobs with TinyUmbrella then you can updating by "stitching" these blobs to the IPSW with redsn0w. If you have not saved SHSH blobs for your phone while apple signed them, there is nothing you can do now. :(

Apple use cryptographic signatures specific for each phone to prevent installing anything but the newest iOS. That can only be bypassed if you got these signatures while Apple still issued them - and only on "older" devices (anything but the iPhone 4S and the iPad 2 and 3).