Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

makismagoo99

macrumors regular
Original poster
Aug 17, 2006
229
0
So here's what happened. I went out and got a shiny new iPhone 5S. At the Apple Store, they activate the phone and start the iCloud restore process (which continues after I get home and re-connect to WiFi). The restore from iCloud was taking FOREVER and a few apps would NOT download, so I used iTunes to create a backup from my old 4S, and restored from the new backup.

After doing that, I thought woohoo! I can check out the iWork apps since they are free with my shiny new iPhone. But they show up as $9.99. So after some googling, I read you might need to log out of the App Store, reboot, and log in again. No problem, so I log out and reboot.

Now we hit our problem. I can't log back in. The Settings app does nothing when I type in my Apple ID and password. Worse, the popup alert asking me to sign in with my Apple ID pops up again and again, but disappears before I can type in anything.

I'm at a loss for ideas, can anyone help?
 

makismagoo99

macrumors regular
Original poster
Aug 17, 2006
229
0
You hit the nail on the head. I was hoping it was a simple setting or app that caused the weird behavior, but after trying a few different things I threw in the towel. I created another new backup from my 4S, and restored the 5S to factory settings with iTunes. Then I chose to restore it from backup and everything is working perfectly again. Thanks!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.