Apple just can't fix my iMac

Discussion in 'iMac' started by 007bond, Mar 9, 2010.

  1. 007bond macrumors 6502a

    007bond

    Joined:
    Dec 12, 2008
    Location:
    DFW, Texas
    #1
    After multiple attempts, I still cant fix the major display issues on my iMac. Pink spots, Blotches, and lines through the screen. Apple replaced the LCD multiple times and still did not resolve the issue. They won't replace it, basically giving me B.S. about it not being their problem and they are saying that they can't give me the right graphics card for replacement(I ordered the ATI 4850 BTO 24in iMac and they want to give GT120). How can I get them to know my iMac is a Lemon and I desperately need a replacement? :mad:
     
  2. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
    #2
    Is it still under warrenty? If it is, keep taking it back. Also, contact your state attorney general if it doesn't get fixed if its under warrenty. You might want to contact apple if you have been dealing with the local apple store. Might work. Good luck.
     
  3. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #3
    You can try contacting the department of customer rights and ask how would they deal with this.

    DON'T accept the GT120 version, you paid for the 4850 and you must get one. Keep taking it back and sooner than later, they have to replace it with either new 24" with 4850 or with similar 27"
     
  4. 007bond thread starter macrumors 6502a

    007bond

    Joined:
    Dec 12, 2008
    Location:
    DFW, Texas
    #4
    I called apple a second time after posting and they told me to download the capture data app from an email she sent me then put another file and email it to her. They are going to contact me on friday to see what they can do. I feel kind of angry but i guess its just my bad luck. Hopefully they can fix it and get me either a working mac or a new iMac:eek:
     
  5. definitive macrumors 68000

    definitive

    Joined:
    Aug 4, 2008
    #5
    i have the same (or similar) issue, but i'm not too bothered by it at the moment. it mostly occurs on the left side of my screen, and lines (from image persistance) go across the top (web browser) and bottom (also any window) of the screen. it may have something to do with the system overheating, not sure, because each time i'll start up some cpu/gpu/hd intensive app, the artifacts remain on the screen after about 15 minutes.

    don't settle for that. call up the tech support instead, and have them pick it up (if you have a spare system) free of charge and repair it at their place because of such an inconvenience.
     

Share This Page