Apple Keyboard Driver Failed Install (Unsigned).

Discussion in 'Windows, Linux & Others on the Mac' started by InSides, Jun 27, 2009.

  1. InSides macrumors newbie

    Joined:
    Jun 6, 2007
    #1
    I just got my MBP (C2D) back from Apple as they were replacing the hard drive, and updating to Leopard.

    I went ahead and installed Windows XP via BootCamp, and that went without a problem.

    However, after running BootCamp installation under Windows, while every other driver got installed with no problems, I noticed that the media keys were not working, along with the eject button and any combination with the Fn key. Checked the settings under the BootCamp application and still problems.

    So I tried to manually install the Apple Keyboard Driver, but the installation fails with a note [Cannot Install (Unsigned)].

    Any thoughts?
     
  2. NCRAW macrumors newbie

    Joined:
    Nov 17, 2007
    #2
    I have the same exact problem. no eject no media. Its intermittent, sometimes they come back to life after a shutdown and restart and sometimes not. the buttons are working as the F functions do what they are suppose to do.for me it happened after windows did an update.

    Can i ask u where do u get the mac alum keyboard driver from? i ran bootcamp 2.1 again and worked ok after restart but now back to the same issue!!
     
  3. NCRAW macrumors newbie

    Joined:
    Nov 17, 2007
    #3
    Not sure if this will help ya but i found what the problem was with the media keys. Issue is that Bootcamp manager (a file u will find under programme files/bootcamp - the diamond grey symbol) is not loading up at start up sometimes. there is a programme that is stopping it from loading. I recall in the latest windows xp update there was a new software to block malicious software or programmes. tryin to sort it out
     

Share This Page