Apple Logo stuck on iphone screen - cannot restore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by spiderbiz, Jul 1, 2009.

  1. spiderbiz macrumors newbie

    Jul 1, 2009
    I recently upgraded my iphone to 3.0. Then used redsn0w-mac_0.7.2 to jailbreak it. No problem doing that. My phone worked great.

    Yesterday I added an app or two from Icy and had never rebooted my phone after that until later in the day.

    Once I completely turned off my iphone - it came back with the white Apple logo and has never gone away since.

    Now I cannot restore in iTunes. Cannot do anything.

    Itunes reports that I have the wrong firmware but when I point to my restore point ipsw file using the option button - restore in iTunes ( I have a macbook ) - it will not read any of my restore points.

    I have read everywhere I can and tried everything I know but I still am locked up. Nothing seems to help.

    I want to wipe out my entire iphone and start over.

    I have good backups so I can get all my apps back but I can't even get there now.

    Please help if you can.

    Email me if you want to - I am desperate here.

  2. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK

Share This Page