Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
Hello guys

I recently bought the new MacBook Pro With the M1 chip.
During use I noticed when I put it in its sleeve after switching the device off, it automatically boots up. I really don't understand how this is possible. As soon as it is halfway inside the sleeve you immediately hear the start-up sound and it boots into the operating system.

Afterwards I tried to disable automatic booting via the command sudo nvram AutoBoot=%00 but this just doesn't seem to work.
Even for opening the lid this does not work it always just starts up (on key press, on opening lid and on putting in it's sleeve)
Is this a problem or bug because it is the M1 model or because macOS BigSur needs a new command line to change this ?
Ever since why does this device start up when you put it in a sleeve, this can't be right how does it even know it's being placed inside it's sleeve.

I hope I am not the only one with this strange behaviour.

Added an image with the sleeve displayed it has a small magnetic part to use it like a stand (like the iPad smart case)
(I had no issues with the magnetic part on the back when I used it with my old MacBook Pro)

Best regards


Update: 30/11/2020
The cause of this behavior must be due to magnetic contact (all the way left and right of the screen at the back). It seems that when the screen detects this, it thinks the lid is opening when it is not. This interrupts the sleep function and starts the MacBook automatically when it is off. The command line to shut down AutoBoot doesn't seem to work on the M1 model either. The only solution I have is to buy a new case or sleeve and stay away from the back of the screen with all that is magnetic.
 

Attachments

  • tempImagejlVaKj.png
    tempImagejlVaKj.png
    3.5 MB · Views: 1,075
Last edited:

NT1440

Contributor
May 18, 2008
12,829
16,698
I thought my 2015 MBP had constant battery drain from an SSD upgrade I did.

6 months later I found out (last week) that I had simply forgotten I had set the computer to boot at 6:30am every day.

Sooooo, check the “it’s so stupid I’d never think to look” settings first, you never know 😉
 
  • Like
Reactions: BigMcGuire

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
Are there magnets in the sleeve somewhere?
Yes it has a magnet strip on the back to use it like a small stand off (like the smart case for the iPad)
I also thought it had something to do with this but why has this never happened with my previous MacBook? and only with this one. It is the same sleeve. The only thing it could be is that the new macbook is more sensitive to magnets.
 

bobmans

macrumors 6502a
Feb 7, 2020
512
1,328
Yes it has a magnet strip on the back to use it like a small stand off (like the smart case for the iPad)
I also thought it had something to do with this but why has this never happened with my previous MacBook? and only with this one. It is the same sleeve. The only thing it could be is that the new macbook is more sensitive to magnets.
I’m just guessing but older Macbook Pros didn’t have this kind of “instant turn on” or whatever Apple advertised with the M1 Macs. Maybe that has something to do with it, maybe it’s triggered by magnets or something?

I guess you could try out at an Apple store if units there have the same behavior or not.

It’s a very interesting bug and magnets triggering something is the only thing that I can think of
 

ThemePro

macrumors demi-god
May 1, 2010
133
93
My M1 MacBook Pro has twice booted up with the lid closed and not even in a sleeve.

In Intel Macbooks 2016 or later, you can disable auto-boot (e.g. raising the lid) with the terminal command sudo nvram AutoBoot=%00 to disable or sudo nvram AutoBoot=%03 to re-enable. With my M1 MacBook, those commands can be entered but don't actually do anything. I tried other variations such as AutoBoot=False; that was a big mistake as it prevented booting at all and had to use recovery mode and select the startup disk to get it to boot again.

So it possible to disable auto-boot of the new M1 MacBooks or how can one even reset the NVRAM / PRAM?
 

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
My M1 MacBook Pro has twice booted up with the lid closed and not even in a sleeve.

In Intel Macbooks 2016 or later, you can disable auto-boot (e.g. raising the lid) with the terminal command sudo nvram AutoBoot=%00 to disable or sudo nvram AutoBoot=%03 to re-enable. With my M1 MacBook, those commands can be entered but don't actually do anything. I tried other variations such as AutoBoot=False; that was a big mistake as it prevented booting at all and had to use recovery mode and select the startup disk to get it to boot again.

So it possible to disable auto-boot of the new M1 MacBooks or how can one even reset the NVRAM / PRAM?
I made the same mistake, found out there was an "auto-boot=true" variable and changed it to false, after rebooting the system I got a white exclamation mark on the screen. After entering recovery and selecting the boot disk it was fixed again. But the AutoBoot=%00 command does indeed not work on this new device.
 
  • Like
Reactions: ThemePro

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
Why turn off your Mac? M1s are designed to be always on
If it was only that problem this couldn't hurt but the thing is the magnetic contact is also keeping the Macbook awake all the time, no sleep, no shutdown. Constant with the display on with the lid closed. This will likely drain the battery in that case.
 

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
I’m just guessing but older Macbook Pros didn’t have this kind of “instant turn on” or whatever Apple advertised with the M1 Macs. Maybe that has something to do with it, maybe it’s triggered by magnets or something?

I guess you could try out at an Apple store if units there have the same behavior or not.

It’s a very interesting bug and magnets triggering something is the only thing that I can think of
It is indeed because of the magnetic contact, I tried with the clip from my phone case (which is a little bit magnetic to keep it closed) touching the outer right and outer left back of the screen. Conclusion the device turns on immediately.
I tried this with the lid open and closed when the device was turned off.


The only solution I think is buying a new sleeve with no magnetic parts inside.

Could this be problematic, that the device is so sensitive to magnetic contact?
I've never seen a laptop respond to anything like this.
 

LuisN

macrumors 6502a
Mar 30, 2013
647
546
Torres Vedras, Portugal
It is indeed because of the magnetic contact, I tried with the clip from my phone case (which is a little bit magnetic to keep it closed) touching the outer right and outer left back of the screen. Conclusion the device turns on immediately.
I tried this with the lid open and closed when the device was turned off.


The only solution I think is buying a new sleeve with no magnetic parts inside.

Could this be problematic, that the device is so sensitive to magnetic contact?
I've never seen a laptop respond to anything like this.
All MacBooks are sensitive to magnetic fields. The "sleep" switch is magnetic. I had that same problem piling one MacBook on top of another one.
 
  • Like
Reactions: gmwalk

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
All MacBooks are sensitive to magnetic fields. The "sleep" switch is magnetic. I had that same problem piling one MacBook on top of another one.
And if we were able to disable the Autoboot on the NVRAM should it then still turn on the device like this?
 

anubis1980

macrumors 6502a
Oct 22, 2012
527
344
we had a guy at work who came down to the IT dept, furious his new laptop kept going to the Lock Screen when he typed. He was adamant we gave him a rubbish laptop etc. he was ranting for 20 mins when I said take off your magnetic bracelet haha.
 
  • Like
Reactions: gmwalk

circatee

macrumors 65816
Jul 18, 2020
1,266
757
Not read through all the responses. But, when placing the laptop in the sleeve, does it only fit one way?
If no, flip it the other way, so the screen is on the opposite side that you normally put it in.

Then, see what happens.
 
  • Like
Reactions: LuisN

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
Are you able to return the sleeve? Was it an Apple branded one?
No it was a cheap one and not an Apple brand. I bought a leather sleeve this morning with no extra functionality this time. I used the sleeve with my old MacBook 2016. And like was said only the newer MacBook models have this magnetic functionality in the screen so that's why it was never an issue with my old laptop I guess.
 

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
Not read through all the responses. But, when placing the laptop in the sleeve, does it only fit one way?
If no, flip it the other way, so the screen is on the opposite side that you normally put it in.

Then, see what happens.
Yea I tied both positions. The magnetic part is on the middle back of the sleeve. I Also pulled
the part that flips open and away from the sleeve when pushing the device inside and still it triggers to boot or wakeup.
 

NT1440

Contributor
May 18, 2008
12,829
16,698
It is indeed because of the magnetic contact, I tried with the clip from my phone case (which is a little bit magnetic to keep it closed) touching the outer right and outer left back of the screen. Conclusion the device turns on immediately.
I tried this with the lid open and closed when the device was turned off.


The only solution I think is buying a new sleeve with no magnetic parts inside.

Could this be problematic, that the device is so sensitive to magnetic contact?
I've never seen a laptop respond to anything like this.
It’s not that it’s “more sensitive” it’s that your sleeve just so happens to line up with the particular magnet sensor on this machine.

I actually have a similar thing happen at work. I replaced two ThinkPads for a user and her machine was still going to sleep “randomly”. I went to her and asked her to try to replicate it. It shut off with her just typing.

Only then did I realize she was wearing an Apple Watch with a third party band in it. I asked her to hand it to me and I slid it along the palm rest and lo and behold at a very particular spot it triggered the “lid closed” sensor.

I’ve rolled “are you wearing a smart watch or FitBit” into my normal troubleshooting script when diagnosing sudden shutdowns.

So, to get back to the point, sometimes you just get unlucky with accessories and how they line up with sensors 🤷‍♂️
 

faba002

macrumors newbie
Original poster
Nov 29, 2020
9
1
It’s not that it’s “more sensitive” it’s that your sleeve just so happens to line up with the particular magnet sensor on this machine.

I actually have a similar thing happen at work. I replaced two ThinkPads for a user and her machine was still going to sleep “randomly”. I went to her and asked her to try to replicate it. It shut off with her just typing.

Only then did I realize she was wearing an Apple Watch with a third party band in it. I asked her to hand it to me and I slid it along the palm rest and lo and behold at a very particular spot it triggered the “lid closed” sensor.

I’ve rolled “are you wearing a smart watch or FitBit” into my normal troubleshooting script when diagnosing sudden shutdowns.

So, to get back to the point, sometimes you just get unlucky with accessories and how they line up with sensors 🤷‍♂️
Yea indeed in my case this is just bad luck I guess. I'd rather buy a new case or sleeve instead that there is something wrong with my new device. The only problem that now remains is that as with previous devices, we cannot turn off the AutoBoot using the command line. To be honest, I'm not much of a fan of the autoboot feature when lifting the screen.
 

IvoryChopsticks

macrumors newbie
Nov 15, 2020
10
7
I thought my 2015 MBP had constant battery drain from an SSD upgrade I did.

6 months later I found out (last week) that I had simply forgotten I had set the computer to boot at 6:30am every day.

Sooooo, check the “it’s so stupid I’d never think to look” settings first, you never know 😉
You can set your computer to boot at a specific time? This is news to me. How do you do this?
 

NT1440

Contributor
May 18, 2008
12,829
16,698
You can set your computer to boot at a specific time? This is news to me. How do you do this?
System Preferences>Battery>Schedule

Check off “start up or wake” and choose your time.

This is Big Sur, the verbiage may be a little different in older machines.
 

Brask

macrumors member
Mar 2, 2020
35
15
Denmark
The so called 'AutoBoot feature' is really annoying. I need to be able to disinfect the keyboard on a regular basis and this is not possible when the M1 machine keeps booting as soon as any key is touched. I have noticed at setting in the nvram called 'AutoBoot' being set as 'true'. From previous post both here and elsewhere I understand that this setting control the AutoBoot feature and on older machines (before M1) it was possible to switch off the autoboot feature by issuing the command 'nvram AutoBoot=%00'. But apparently this will not work on the M1 machines. I can still issue the command but it has no effect. I have taken this up with Apple Support, but Apple Support refuses to give any advise on how to manipulate the configuration through the use of commands in terminal🤬
I have a strong feeling that it should still be possible to change the AutoBoot setting in nvram but I need some advise as to exactly how. I even tried using the security settings (holding the start button for a few seconds at start) but no luck so far.
Any advise on this will be appreciated.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.