Apple Magic Mouse issues Windows 7

Discussion in 'Windows, Linux & Others on the Mac' started by lannisters4life, Jul 10, 2012.

  1. lannisters4life macrumors 6502

    Joined:
    May 14, 2012
    Location:
    Sydney
    #1
    Hey all, I've got some annoying issues with my Apple mouse in Windows 7. Most of the time it's so terribly laggy that I use the trackpad on my MBA instead, but then occasionally I'll use it and it will work perfectly. I've tried repositioning my MBA on my desk to be closer to where the mouse is, perhaps there was some wireless interference with my Thunderbolt display (I've read about this) but nothing seems to help. I tried removing it from the Windows mouse section and having the bluetooth assistant reinstate it, to no avail, and now after doing this I can't scroll at all, which I could do before. Anyone had any issues with this too? Any proposed solutions? Thanks.
     
  2. PaulKemp macrumors 6502

    Joined:
    Jun 2, 2009
    Location:
    Norway
    #2
    Hi! While I dont currently use windows 7 on my iMac I did have some issues with it in win 7. It took like two minutes to connect, but once connected, performed as advertised. There was so many issues I left win 7 behind.

    While troubleshooting this issue I tried some alternative drivers both for the bluetooth adapter and the mouse itself. I dont know with your laggy performance, but one user sais "I had to click the buttom once to make it work".

    I tried the suggestions from this thread. Good luck!
    https://discussions.apple.com/thread/2221427?start=0&tstart=0

    edit: I remember one potential fix, you could try to reset the pram (Command, Option, P, and R during boot).
     

Share This Page