Apple Mail app and GMail IMAP - problems deleting mail

Discussion in 'Mac Basics and Help' started by blairwillis, Feb 29, 2008.

  1. blairwillis macrumors regular

    Joined:
    Jul 24, 2005
    #1
    I've been using Apple's Mail app with GMail via IMAP for a while with good results. Sometime in the last several days (perhaps with the OS X 10.5.2 update???) I've begun experiencing problems:

    Deleting a message in Mail causes the message to disappear, then pop right back up, only grayed out. Using cmd-L will make it disappear, but the problem returns. (I've never had to use cmd-L in the past.)

    Sending and Receiving mail seems very slow (viewed in the "Mail Activity" area) and sometimes appears to hang up completely.

    Mail takes forever to quit, won't quit, or requires a force-quit.

    After restarting mail, the "deleted" messages will reappear in my inbox.

    Any ideas? Anyone else experiencing similar symptoms?

    Thanks,
    Blair
     
  2. bmwpowere36m3 macrumors 6502

    Joined:
    Nov 8, 2007
    #2
    I've had the same problem, when deleting a message in the GMail Inbox. After deleting a message it just reappears. So what I do is "right-click" and select Move To - [Gmail] - Trash and that appears to work. But yea, that problem bugged me at first.
     
  3. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #3
    From google:
    So the best way to delete messages is to drag them to gmail's Trash folder.

    I've given up using gmail's IMAP implementation because of problems like this.
     
  4. blairwillis thread starter macrumors regular

    Joined:
    Jul 24, 2005
    #4
    Stomer, thanks for the tip. That worked perfectly. Turning off the "store deleted messages on server" option cleared up the problem immediately.
     
  5. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #5
    It didn't work for me. Same old problem. Deleting a message in the Gmail Inbox causes the message to disappear and to come right back, but deleting it from the Gmail All Mail folder seems to really delete it.
     
  6. xanatos macrumors regular

    Joined:
    Oct 18, 2007
    #6
    Im having the same problem and its driving me insane!

    Even when i turn off all the "save on server" stuff it still pops up after i delete it..ugh!
     
  7. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #7
    I had a lot of these same problems until I deleted my gmail account in mail.app and recreated it according to gmail's directions (to the letter). Now everything works exactly as it should. You need to be very careful about how yu set the Mailbox Behaviors options. I did this on both my home and business machines and it has worked great ever since.
     

Share This Page