Apple Mail Client no longer working after syncing with MobileMe

Discussion in 'Mac Basics and Help' started by Glumpfner, Jan 23, 2011.

  1. Glumpfner, Jan 23, 2011
    Last edited: Jan 23, 2011

    Glumpfner macrumors regular

    Joined:
    Dec 15, 2009
    #1
    Hi there,

    So here is what happened exactly in the following order:


    - Had a MacBook Pro 15" using Mail as my main email client.
    - Had 5 IMAP accounts set up (1GMail, 1MobileMe, 3 own domains-hosted also at Google via Google App)
    - Had passwords of those 5 email synced to MobileMe keychain.
    - Sold my old 15" MacBook Pro
    - Changed Password of Gmail account and 3 own domains while I had no laptop for a few days
    - Got new 13" MacBook Pro
    - Configured Mail and Added all my 5 E-Mail accounts again. Everything worked perfectly.
    - Afterwards a few days realized I did not have MobileMe Keychain sync active.
    - When activating Syncing keychain I accidentally clicked "Overwrite local Keychain with MobileMe one".
    - Because I changed my passwords of my GMail and my 3 own Domain email accounts between the last sync of MobileMe, the passwords were obviously not working.
    - Mail prompted me for the new password. I entered it. Password was accepted for GMail Account and 2 out of the 3 of my own domains, but for some strange reason not for the 3rd domain! Tried loads of times over several days, restarted the MacBook. Even removed the email account in Mail and added it again. It just won't accept the password. Password works via Webinterface and still on my iPhone, just no longer on Mail.
    I noticed every time I open up Mail preferences the password field of that email account is empty! Although I enter it, save it but as soon as I go back to the preferences, it's empty again.

    Another thing that happened a few hours later, my GMail account stopped working! Although it worked perfectly before! (even after the accidental sync and re entering the correct password then)
    It's not asking for the password, it's not giving me an error message, nothing at all, it just has the little "in progress circle" next to the mailbox name, saying it's working, but nothing ever happend. No emails fetched in the past 12 hours and keep saying it's busy. When logging into GMail web interface there are at least 30 new emails. Gmail still works on my iPhone. Restart of MacBook did not help.

    The 3rd Thing is, the same time GMail stopped working, the outbox seems VERY slow.
    I sent 5 emails, plain text and it took almost 3 hours for them to be sent! It keeps saying 0KB or 0.1KB/s when sending. My internet is definitely faster than that. Restart also did not help.

    I wonder if any of that has to do with the fact that I am traveling a lot in the past 3 days. Moved from Ireland to Canada and I am in StarBucks and different friends places a lot.
    All the passwords still work, so nothing has been hacked. And E-Mails, are being sent normal speed from my iPhone via the same WiFi connection, so it's not my friends internet nor Starbucks.

    Bottom line:
    Since accidentally syncing with MobileMe Keychain, every thing is messed up! I even turned off mobileme keychain sync, but doesn't help.
     
  2. MacTribe macrumors member

    MacTribe

    Joined:
    Dec 26, 2010
    Location:
    London
    #2
    2 things you can try:

    a) Try deleting the .OfflineCache folder - follow my guide here

    b) Start over. Reset Mail completely by deleting your Mail folder found in home folder / Library...

    Also delete the com.apple.mail.plist file found in your home folder / Library / Preferences

    Hope this helps. Let us know how you get on..
     
  3. Glumpfner thread starter macrumors regular

    Joined:
    Dec 15, 2009
    #3
    Hi MacTribe,

    Thanks a lot for you help.

    I did a reset as you said and it seems to have worked for the GMail accounts and all the syncing issues are gone.

    However the one e-mail account that did not accept the password, is still not accepting it and I am at a lose.
    It's a private domain that uses Google Apps for E-Mails. It worked perfectly fine before, and it's still works on my iPhone but on Apple Mail client it just won't accept the password.

    I logged into the Google Apps E-Mail web interface and the password works. I also made sure IMAP is active and another thing I heard is that now and then the accounts need to get the CaptchaUnlocked via the domain https://www.google.com/a/yourdomain.com/UnlockCaptcha which I did successfully, but still not accepting the password.

    I'll use MS Outlook and see if the problem is the same there, just to narrow it down.
     
  4. Glumpfner thread starter macrumors regular

    Joined:
    Dec 15, 2009
    #4
    Little follow up here.

    Turns out the password issue was the https://www.google.com/a/yourdomain.com/UnlockCaptcha all I had to do was to unlock it there and then restart my laptop. Restarting Mail client alone did not work.

    And all the other speed issues and syncing issues disappeared when resetting the entire mail client as you said.

    So, Problem solved thanks for the helo :)
     

Share This Page