Apple Mail CPU and other issues

Baklava

macrumors 6502a
Original poster
Feb 1, 2010
567
42
Germany
My Mail is using 40-60% of the CPU. Is it just me? Another big issue: scrolling though the mailboxes and folders on the left side is not working properly. Every time I scroll down the list, the scrollbar goes up itself. Has someone else that issue?

EDIT: The CPU goes back to normal when I disable all mail accounts. But that's not the sense of Mail. :D
 
Last edited:

liv2wrshp

macrumors member
Oct 7, 2003
49
1
chicago
My Mail is using 40-60% of the CPU. Is it just me? Another big issue: scrolling though the mailboxes and folders on the left side is not working properly. Every time I scroll down the list, the scrollbar goes up itself. Has someone else that issue?

EDIT: The CPU goes back to normal when I disable all mail accounts. But that's not the sense of Mail. :D
Does the same thing for me. It's been over 100% for over an hour.
 

cecoleman

macrumors regular
Nov 13, 2007
232
3
Mail is crashing a lot for me. Sucks... Everything else is soooo gooood. Any fixes out there for this?
 

bibyfok

macrumors 6502
Jun 14, 2012
335
6
France
Mail is crashing a lot for me. Sucks... Everything else is soooo gooood. Any fixes out there for this?
Go to Windows/activity --> Loop with an account? For me its my googleapps account that keep refreshing in a loop... :/
 
Last edited:

Baklava

macrumors 6502a
Original poster
Feb 1, 2010
567
42
Germany
Go to Windows/activity --> Loop with an account? For me its my googleapps account that keep refreshing in a loop... :/
EXACT problem here. Have multiple accounts, one of them is Google Apps. Deactivating Google-Account fixes the CPU problem. Activating it, rockets the CPU usage again to about 50.

EDIT: Yes, same here! Endless refresh-loop.
 

Atmos4

macrumors newbie
Apr 15, 2013
10
0
I think this happens with international GMail accounts where the special folders don't match with what Mail expects. Eg. for German GMail account the drafts folder is at [Google Mail]\Entwürfe but Mail expect [Google Mail]\Drafts so when saving a Draft it creates a new folder/label [Imap]\Drafts and starts constantly polling the GMail server/eating CPU.

Try removing those labels created by Apple mail through the GMail web interface settings -> labels and restart mail. In my case that solves the constant polling until I save a new draft…
 

bakerzdosen

macrumors member
Apr 11, 2006
58
12
Well, just to add to this...

I upgraded to 10.9 last night. There was a lot of md_stores/mdworker activity that happened for a while (as expected) and then I opened Mail.app...

Several (4 of 8?) CPU's suddenly were pegged. Part of it was internet accounts and part was Mail.

It took a while for Mail to even respond (an hour?), but the CPUs were still pegged. After 5 or so hours I gave up and put the system to sleep.

Suffice to say, this morning, it ran out of application RAM. (Of the 8GB of RAM, it was well over 5GB and Mail.app was the only app running other than the Finder.) Every time I would launch Mail.app it would run out of Application RAM within 2 minutes (prior to being responsive - meaning I couldn't disable accounts, and yes, I tried disabling networking, but this was all just dealing with everything on the hard drive.)

I eventually gave up and deleted my ~/Library/Mail folder and started from scratch. It's not going to be fun downloading all of my mail again (I know I was just shy of 7000 *unread* messages from 7 different accounts - 4 of which are gmail, and the largest of which has ≈130k messages in it) but if it works, I suppose it will end up being OK.

At least I didn't have any POP accounts.

Thus far this has been my only (yet quite major) issue with 10.9.
 

joblolabinette

macrumors newbie
Jul 18, 2011
2
0
I think this happens with international GMail accounts where the special folders don't match with what Mail expects. Eg. for German GMail account the drafts folder is at [Google Mail]\Entwürfe but Mail expect [Google Mail]\Drafts so when saving a Draft it creates a new folder/label [Imap]\Drafts and starts constantly polling the GMail server/eating CPU.

Try removing those labels created by Apple mail through the GMail web interface settings -> labels and restart mail. In my case that solves the constant polling until I save a new draft…
I was wondering why 2 of my 3 Gmail acounts where the culprits, and thos 2 were in french and the third was already in english, I put all my account in english and CPU usage immidiately fell!

Thank you for your tip!
 

MartyCan

macrumors 68000
Oct 31, 2012
1,510
343
Near Toronto, ON
I had a problem with mail too after upgrade on my MBPr. Out of nowhere an old pop version of my gmail account showed up (swear I don't know how) and made itself default. Took me too long to figure out that there were two versions (pop and imap) of the same account. Inactivated the pop version and everything started to behave better.
 

kristapsz

macrumors newbie
Jan 8, 2008
3
0
After upgrading, I also had problems with Mail. When I tried to open it, it would stuck half open, eat CPU and wouldn't show any mailboxes. After couple of restarts, I decided to open and wait. Then couple of hours later it suddenly was working again :)
 

nothin7

macrumors newbie
Oct 7, 2011
5
0
I noticed that my Accounts.plist file in ~/Library/Mail/V2/MailData had grown to a massive 70 MB. Simply deleting this file fixed the issue (the new Accounts.plist is only 10 KB). I had to set up my Gmail accounts again, but it was a snap in Mavericks, and all of my preferences and messages are intact (since I didn't delete any of the other folders).