Apple Mail downloads Gmail's spam automatically

Discussion in 'Mac Apps and Mac App Store' started by mattwrit, Dec 8, 2008.

  1. mattwrit macrumors member

    Joined:
    Dec 8, 2008
    #1
    I've set up Apple Mail and Gmail via IMAP but am concerned that it automatically downloads all my spam, too. Could I not get malware etc. by it doing that?

    Also, when I'm wrtiting an email, every couple of minutes it seems to save a draft on Gmail's server. If I log in to Gmail it's littered with hundreds of half-written emails.

    Can I stop it doing these things?!
     
  2. drichards macrumors 6502a

    drichards

    Joined:
    Nov 30, 2008
    #2
    Mine leaves spam alone on gmail servers, but I use POP for gmail. Try POP, it ignores the trash, spam, and chats folders.
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    No, don't switch to POP, IMAP has a number of advantages.

    First, go into your Mail Preferences, choose the account in question from the Accounts pane, click Advanced, then deselect "Store draft messages on server". I agree, that's really annoying behavior.

    Then, log into the online Gmail interface, click on the Labs button up top (looks like a green beaker), or you can get to it by choosing Settings, then Labs, and find the section for Advanced IMAP controls. Enable it, making sure to save the preferences, then go to the Labels section of settings, find the Spam label, and deselect the "Show in IMAP" checkbox. Now your Gmail spam will not show up to Mail or other IMAP programs.

    jW
     
  4. dzamo macrumors newbie

    Joined:
    Jan 2, 2010
  5. spsoni macrumors newbie

    Joined:
    Jul 17, 2011
    #5
    I tried the same, I could not find "Advanced IMAP controls" thing in Labs tab. But it is no longer required as well. You can directly jump to "Labels" tab and choose which folders to be visible in IMAP. Thanks for this help. It works for me.
     

Share This Page