apple mail + gmail imap = no read status update?

Discussion in 'Mac Basics and Help' started by Toby Goodbar, Jan 25, 2010.

  1. Toby Goodbar macrumors 6502

    Sep 8, 2006
    I know i am not the only one w/this problem but i wanted to post and see if anyone has found a solution of if there has been an update. i googled around today to no avail.

    gmail imap read status does not update in apple mail until its restarted. If i read an email on my iphone, it will show as read in iphone mail, gmail web interface, but NOT apple mail unless its been restarted.

    if the email is read in apple mail, the gmail interface will show it as read, as will the iphone.

    surely apple is aware of the issue? has this been fixed in snow leopard? anyone discovered any work arounds?

    feel free to post here, even if you have no answers, you jus happen to also suffer from this "affliction"
  2. GGJstudios macrumors Westmere


    May 16, 2008
    Mine updates as soon as I do a "Get Mail" in, either manually or automatically, every minute.
  3. Toby Goodbar thread starter macrumors 6502

    Sep 8, 2006
    are you using google imap?

    and are you READING your mail SOMEWHERE OTHER than apple mail first?

    if so please post your settings
  4. tsg20 macrumors member

    Jul 25, 2007
  5. waynep macrumors 6502

    Dec 31, 2009
    I use gmail and imap with Works fine for me. I just tested this to make sure. Sent email from yahoo account to gmail. Got it on Read it on my iPod and it was quickly marked as read in without me doing anything on the Mac.
  6. twach macrumors newbie

    Dec 19, 2009
    Not working for me

    Running lion on 3 computers, iPhone and iPad. Read status is not updating across machines.
  7. Matthew9559 macrumors 6502a


    Apr 7, 2007
    Cleveland, OH
    I haven't had this problem yet. Running OS X Lion.

    Have you tried deleting/adding gmail to Mail app again?
  8. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    Plus if you are in Lion open System Preferences->Mail, Contacts & Calendars and check your GMail settings there. You can delete the entry and re-add it from there also.

Share This Page