Apple Mail & Keychains

Discussion in 'Mac Basics and Help' started by drgrafix, Dec 21, 2008.

  1. drgrafix macrumors regular

    Joined:
    Feb 9, 2008
    Location:
    New England
    #1
    I have this weird issue that seems to have started a few months ago and its become annoying enough that I have to ask for some advice. First, comcast is my broadband carrier, and I haven't changed emails for years and everything seemed fine for roughly the first 6 months in the iMac switchover.

    But now, roughly half the time I access the mail program, I'm being asked to provide my account PWs and sometimes it takes 3 or 4 tries to get it to accept the PW and get my mail. And I always check the box that asks if you want this information stored on the "keychain" but a few days later when it happens again... the box is unchecked and its asking me to again enter my PW and do I want to store the info on the keychain.

    I have called comcast twice on this issue and they tell me its not them asking for the PW because what I have stored on the machine matches their records and files. They said it's probably something in my mail program settings.

    Anyone else having similar problems?
     
  2. Victor Star macrumors member

    Joined:
    Dec 3, 2008
    #2
    I have that problem from time to time with Time Warner Cable. If you have access to your mail over the internet, web browser, then try it from there. If you have problems there call Comcast back and show them. That should prove the problem is on them. If you don't have problems it would point to a problem on your machine or with your mail client. I would probably delete my accounts in the mail client and entries in keychain then recreate them.
     
  3. drgrafix thread starter macrumors regular

    Joined:
    Feb 9, 2008
    Location:
    New England
    #3
    I never seem to have any problem accessing comcast mail from a browser, but it's just a PITA. I also wonder if having an email on my machine with a mac.com address that is only used for emailing photo galleries is confusing the apple mail server?
     

Share This Page